summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-10-22 22:59:28 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-10-22 22:59:45 +0200
commite404d6818cb47382e09284a27b576830f1d01175 (patch)
tree900f395bb94aa5c92d06e2cbf51f0ce4c286b555 /games-emulation
parentmail-mta/msmtp: Removed old (diff)
downloadgentoo-e404d6818cb47382e09284a27b576830f1d01175.tar.gz
gentoo-e404d6818cb47382e09284a27b576830f1d01175.tar.bz2
gentoo-e404d6818cb47382e09284a27b576830f1d01175.zip
games-emulation/dosbox-staging: skip test failing on some platforms
Also add USE=test logic for gtest dependency Closes: https://bugs.gentoo.org/817908 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
index 1cb6c2e10ce3..1f48dd089fc0 100644
--- a/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl"
+IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl test"
RDEPEND="alsa? ( media-libs/alsa-lib )
debug? ( sys-libs/ncurses:0= )
@@ -28,7 +28,7 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
sys-libs/zlib
!games-emulation/dosbox"
DEPEND="${RDEPEND}"
-BDEPEND=""
+BDEPEND="test? ( dev-cpp/gtest )"
DOCS=( AUTHORS README THANKS )
@@ -41,6 +41,10 @@ src_prepare() {
# Disable license and docs install (handled by ebuild)
sed -e "/licenses_dir\|doc_dir/d" -i meson.build || die
+
+ # Test failing on some platforms, bug #817908
+ # https://github.com/dosbox-staging/dosbox-staging/issues/1230
+ sed -i 's/.*soft_limit.*//' tests/meson.build || die
}
src_configure() {
@@ -52,6 +56,7 @@ src_configure() {
$(meson_use mt-32 use_mt32emu)
$(meson_use network use_sdl2_net)
$(meson_use opengl use_opengl)
+ $(meson_feature test unit_tests)
)
meson_src_configure
}