summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-01-31 14:50:10 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-01-31 14:50:10 +0000
commit9cfa06aa4941e874ad0e84fac574c2b8a8c2d720 (patch)
tree790b721c95c7a5bbc141f94bcb16eaa0fb619747 /games-engines/dMagnetic/dMagnetic-0.30.ebuild
parentnet-misc/curl: remove libressl (diff)
downloadgentoo-9cfa06aa4941e874ad0e84fac574c2b8a8c2d720.tar.gz
gentoo-9cfa06aa4941e874ad0e84fac574c2b8a8c2d720.tar.bz2
gentoo-9cfa06aa4941e874ad0e84fac574c2b8a8c2d720.zip
games-engines/dMagnetic: Bump to 0.30, drop old 0.29
Package-Manager: Portage-3.0.14, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines/dMagnetic/dMagnetic-0.30.ebuild')
-rw-r--r--games-engines/dMagnetic/dMagnetic-0.30.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-engines/dMagnetic/dMagnetic-0.30.ebuild b/games-engines/dMagnetic/dMagnetic-0.30.ebuild
new file mode 100644
index 000000000000..198f5f043725
--- /dev/null
+++ b/games-engines/dMagnetic/dMagnetic-0.30.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit prefix toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="A Magnetic Scrolls Interpreter for playing a collection of old text adventures"
+HOMEPAGE="https://www.dettus.net/dMagnetic/"
+SRC_URI="https://www.dettus.net/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ hprefixify ${PN}.ini src/toplevel/${PN}.c
+}
+
+src_compile() {
+ emake ${PN} \
+ CC="$(tc-getCC)" \
+ LINK="$(tc-getCC) ${LDFLAGS}"
+}
+
+src_test() {
+ emake check \
+ SHA256_CMD=sha256sum
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1 ${PN}ini.5
+ dodoc README.txt
+
+ insinto /etc
+ doins ${PN}.ini
+}