summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-11-02 17:02:45 -0500
committerAustin English <wizardedit@gentoo.org>2016-11-11 13:38:57 -0600
commitd0b0de80d631027926a8dab52d7f60a2e0f57f88 (patch)
treed9d1021b7237c9297d0cafc161afeba04e120237 /games-engines/frobtads/frobtads-1.2.3-r1.ebuild
parentsys-kernel/gentoo-sources: Remove old, vulnerable kernels that are EOL'd upst... (diff)
downloadgentoo-d0b0de80d631027926a8dab52d7f60a2e0f57f88.tar.gz
gentoo-d0b0de80d631027926a8dab52d7f60a2e0f57f88.tar.bz2
gentoo-d0b0de80d631027926a8dab52d7f60a2e0f57f88.zip
games-engines/frobtads: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.2
Diffstat (limited to 'games-engines/frobtads/frobtads-1.2.3-r1.ebuild')
-rw-r--r--games-engines/frobtads/frobtads-1.2.3-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-engines/frobtads/frobtads-1.2.3-r1.ebuild b/games-engines/frobtads/frobtads-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..b0bbc2a20ca6
--- /dev/null
+++ b/games-engines/frobtads/frobtads-1.2.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
+HOMEPAGE="http://www.tads.org/frobtads.htm"
+SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz"
+
+LICENSE="TADS2 TADS3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tads2compiler tads3compiler"
+
+RESTRICT="!tads3compiler? ( test )"
+
+RDEPEND="net-misc/curl
+ sys-libs/ncurses:0"
+DEPEND=${RDEPEND}
+
+DOCS=( doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS} )
+
+src_configure() {
+ append-cxxflags -fpermissive
+ append-libs $(curl-config --libs)
+ econf \
+ $(use_enable debug error-checking) \
+ $(use_enable debug t3debug) \
+ $(use_enable tads2compiler t2-compiler) \
+ $(use_enable tads3compiler t3-compiler)
+}
+
+src_test() {
+ emake -j1 sample
+ ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
+ save
+ testsave.sav
+ restore
+ testsave.sav
+ END_FROB_TEST
+ [[ $? -eq 0 ]] || die "Failed to run test game"
+}
+
+src_install() {
+ default
+}