summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-06-24 22:16:06 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-06-24 22:17:56 +0100
commitc8c3d4394a6f715f2e809f5aa82c80ea0ccb56a4 (patch)
tree1a54c1d4f584ac61258b2eaa7eb9c703b13ba326 /games-engines/scrap-engine/scrap-engine-1.2.0.ebuild
parentapp-i18n/opencc: drop 1.0.5, 1.1.2 (diff)
downloadgentoo-c8c3d4394a6f715f2e809f5aa82c80ea0ccb56a4.tar.gz
gentoo-c8c3d4394a6f715f2e809f5aa82c80ea0ccb56a4.tar.bz2
gentoo-c8c3d4394a6f715f2e809f5aa82c80ea0ccb56a4.zip
games-engines/scrap-engine: New package at version 1.2.0
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines/scrap-engine/scrap-engine-1.2.0.ebuild')
-rw-r--r--games-engines/scrap-engine/scrap-engine-1.2.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-engines/scrap-engine/scrap-engine-1.2.0.ebuild b/games-engines/scrap-engine/scrap-engine-1.2.0.ebuild
new file mode 100644
index 000000000000..05b7700f5b2a
--- /dev/null
+++ b/games-engines/scrap-engine/scrap-engine-1.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_PN="${PN//-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Terminal-based Python game engine involving objects on a map"
+HOMEPAGE="https://github.com/lxgr-linux/scrap_engine"
+SRC_URI="https://github.com/lxgr-linux/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-tests.patch
+)
+
+DOCS=(
+ README.md
+ docs/DOCS.md
+ pics/example1.jpg
+)
+
+src_prepare() {
+ default
+
+ # PEP 517 needs this metadata.
+ echo "Version: ${PV}" > "${S}"/PKG-INFO || die
+
+ # Adjust doc resource paths.
+ sed -i "s:\.\./pics/::g" docs/DOCS.md || die
+}
+
+python_test() {
+ for TEST in "${S}"/tests/*.py; do
+ "${EPYTHON}" "${TEST}" || die
+ done
+}