summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-07-02 21:34:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-07-02 21:48:50 +0100
commit0e81bdf479705e3665ad94da434891adc38b6787 (patch)
tree7fac46643b34071f71fd0660954c14eb1311d8ad /games-engines
parentnet-analyzer/fail2ban: avoid test umask affecting installed files (diff)
downloadgentoo-0e81bdf479705e3665ad94da434891adc38b6787.tar.gz
gentoo-0e81bdf479705e3665ad94da434891adc38b6787.tar.bz2
gentoo-0e81bdf479705e3665ad94da434891adc38b6787.zip
games-engines/odamex: Fix USE=master with upstream patch
Closes: https://bugs.gentoo.org/907745 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/odamex/files/odamex-10.3.0-master-fix.patch31
-rw-r--r--games-engines/odamex/odamex-10.3.0-r1.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/games-engines/odamex/files/odamex-10.3.0-master-fix.patch b/games-engines/odamex/files/odamex-10.3.0-master-fix.patch
new file mode 100644
index 000000000000..1a20d8f6523c
--- /dev/null
+++ b/games-engines/odamex/files/odamex-10.3.0-master-fix.patch
@@ -0,0 +1,31 @@
+From 10beb4212625ee5e6d5b8a55e94d22d70d630217 Mon Sep 17 00:00:00 2001
+From: Jan200101 <sentrycraft123@gmail.com>
+Date: Wed, 19 Apr 2023 14:33:33 +0200
+Subject: [PATCH] include time.h on all platforms
+
+---
+ master/main.cpp | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/master/main.cpp b/master/main.cpp
+index a69af8dd0..3226792a7 100644
+--- a/master/main.cpp
++++ b/master/main.cpp
+@@ -38,16 +38,15 @@
+ #include <string.h>
+
+ #include <stdint.h>
++#include <time.h>
+
+ #ifdef UNIX
+ #include <netinet/in.h>
+ #include <unistd.h>
+-#include <sys/time.h>
+ #endif
+
+ #ifdef _WIN32
+ #include <winsock.h>
+-#include <time.h>
+ #define usleep(n) Sleep(n/1000)
+ #endif
+
diff --git a/games-engines/odamex/odamex-10.3.0-r1.ebuild b/games-engines/odamex/odamex-10.3.0-r1.ebuild
index 594869339e54..0c99afc1d885 100644
--- a/games-engines/odamex/odamex-10.3.0-r1.ebuild
+++ b/games-engines/odamex/odamex-10.3.0-r1.ebuild
@@ -42,6 +42,7 @@ S="${WORKDIR}/${PN}-src-${PV}"
PATCHES=(
"${FILESDIR}"/${PN}-10.3.0-unbundle-fltk.patch
+ "${FILESDIR}"/${P}-master-fix.patch
)
src_prepare() {