summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2021-03-08 09:29:04 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-03-08 09:35:05 +0200
commit7a7657e01bf33cba95cf23d4877106b76f793fee (patch)
treee8b7a0720210c67b92fcc8782b6db73f6a294713 /games-engines
parentsci-geosciences/grass: drop 7.8.4 (diff)
downloadgentoo-7a7657e01bf33cba95cf23d4877106b76f793fee.tar.gz
gentoo-7a7657e01bf33cba95cf23d4877106b76f793fee.tar.bz2
gentoo-7a7657e01bf33cba95cf23d4877106b76f793fee.zip
games-engines/openmw: fix build of 9999
Closes: https://bugs.gentoo.org/773211 Signed-off-by: Alexey Sokolov <sokolov@google.com> Thanks-to: Benjamin Winger <bmw@disroot.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/openmw/files/openmw-0.47.0-bullet-debian.patch15
-rw-r--r--games-engines/openmw/openmw-9999.ebuild10
2 files changed, 19 insertions, 6 deletions
diff --git a/games-engines/openmw/files/openmw-0.47.0-bullet-debian.patch b/games-engines/openmw/files/openmw-0.47.0-bullet-debian.patch
new file mode 100644
index 000000000000..3a8486250a8a
--- /dev/null
+++ b/games-engines/openmw/files/openmw-0.47.0-bullet-debian.patch
@@ -0,0 +1,15 @@
+This condition makes it link to wrong library on Gentoo Prefix on Debian
+--- a/components/CMakeLists.txt
++++ b/components/CMakeLists.txt
+@@ -246,11 +246,7 @@ target_link_libraries(components
+ RecastNavigation::Recast
+ )
+
+-if (BULLET_USE_DOUBLES AND (UBUNTU_FOUND OR DEBIAN_FOUND) AND OPENMW_USE_SYSTEM_BULLET)
+- target_link_libraries(components BulletCollision-float64 LinearMath-float64)
+-else()
+ target_link_libraries(components ${BULLET_LIBRARIES})
+-endif()
+
+ if (WIN32)
+ target_link_libraries(components
diff --git a/games-engines/openmw/openmw-9999.ebuild b/games-engines/openmw/openmw-9999.ebuild
index 70603fec46ab..512ef3855897 100644
--- a/games-engines/openmw/openmw-9999.ebuild
+++ b/games-engines/openmw/openmw-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ RESTRICT="!test? ( test )"
# used when BUILD_OPENCS flag is enabled. See bug #676266.
RDEPEND="
+ app-arch/lz4
dev-games/mygui
dev-games/recastnavigation
dev-libs/boost:=[threads]
@@ -62,7 +63,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/openmw-0.47.0-mygui-license.patch
- "${FILESDIR}"/openmw-0.46.0-recastnavigation.patch
+ "${FILESDIR}"/openmw-0.47.0-bullet-debian.patch
)
src_prepare() {
@@ -70,10 +71,6 @@ src_prepare() {
# Use the system tinyxml headers
rm -v extern/oics/tiny{str,xml}* || die
-
- # Unbundle recastnavigation
- rm -vr extern/recastnavigation || die
- sed -i "s#GENTOO_RECAST_LIBDIR#${EPREFIX}/usr/$(get_libdir)#" CMakeLists.txt || die
}
src_configure() {
@@ -95,6 +92,7 @@ src_configure() {
-DICONDIR="${EPREFIX}/usr/share/icons/hicolor/256x256/apps"
-DMORROWIND_DATA_FILES="${EPREFIX}/usr/share/morrowind-data"
-DUSE_SYSTEM_TINYXML=ON
+ -DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON
-DDESIRED_QT_VERSION=5
-DBULLET_USE_DOUBLES=ON
)