summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2021-09-17 02:09:48 +0300
committerIonen Wolkens <ionen@gentoo.org>2021-09-16 20:36:53 -0400
commit9d7c9ab7f38d4b3d0daa1bb335238d4afdd48a47 (patch)
tree927e9f8a757fcb024dad85761d4d0702949d7ffa /games-engines
parentsys-apps/portage: Fix setuptools warning for bug #795900 (diff)
downloadgentoo-9d7c9ab7f38d4b3d0daa1bb335238d4afdd48a47.tar.gz
gentoo-9d7c9ab7f38d4b3d0daa1bb335238d4afdd48a47.tar.bz2
gentoo-9d7c9ab7f38d4b3d0daa1bb335238d4afdd48a47.zip
games-engines/qtads: bump to 3.1.0, EAPI 8
Closes: https://bugs.gentoo.org/813417 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Nikos Chantziaras <realnc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22312 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/qtads/Manifest1
-rw-r--r--games-engines/qtads/qtads-3.1.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/games-engines/qtads/Manifest b/games-engines/qtads/Manifest
index daf58a6dddc8..545fe9ecb547 100644
--- a/games-engines/qtads/Manifest
+++ b/games-engines/qtads/Manifest
@@ -1 +1,2 @@
DIST qtads-3.0.0-source.tar.xz 5325048 BLAKE2B cb60908e71edb32157638891a58bed83aba01d484821473716c17845094be9232f9e989bad474db27c1e06734b073ee301756b0528ca880e4c40c0994e95bc48 SHA512 e7b72350876475e0b5b9b8c8c953aa380f5f25dade25785d15c5004a6866bb614c3ca2a3b34f84989013e350f9e73d339ce8ddd7d36766d80a981cfbfda7d1c6
+DIST qtads-3.1.0-source.tar.xz 5438292 BLAKE2B 50d4cb8e39ed1da83005f326aa20e595da825acf7b769a4abaa2b319ee9f2da83af435cf676b82d28417ffc751be7ad8ab6bdc09ad3d571a1df068cd1eca48dd SHA512 b79c6e326369c259d293adf8232e7da64b23506ed272a456b57aef3ef92f440d53ca5204bf36a49cae1b783ce864bae1986053d7f0893e70bfbf8877d87b7267
diff --git a/games-engines/qtads/qtads-3.1.0.ebuild b/games-engines/qtads/qtads-3.1.0.ebuild
new file mode 100644
index 000000000000..f865caf33793
--- /dev/null
+++ b/games-engines/qtads/qtads-3.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Multimedia interpreter for TADS text adventures"
+HOMEPAGE="https://realnc.github.io/qtads"
+SRC_URI="https://github.com/realnc/qtads/releases/download/v${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sound"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtwidgets:5
+ sound? (
+ media-libs/libsdl2[sound]
+ media-libs/libsndfile
+ media-libs/libvorbis
+ media-sound/fluidsynth:0=
+ media-sound/mpg123
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5 \
+ PREFIX="${EPREFIX}/usr" \
+ $(usev !sound CONFIG+=disable-audio) \
+ -after CONFIG-=silent
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}