summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-13 08:33:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-04-13 08:33:23 +0200
commit9d9b895c96872255400e584e76e4a75828275eb0 (patch)
treea9f177cb8aa0b4ec4bb480d6133975b2c33f1957 /games-engines
parentmail-mta/postfix: bump to 3.5.10 (diff)
downloadgentoo-9d9b895c96872255400e584e76e4a75828275eb0.tar.gz
gentoo-9d9b895c96872255400e584e76e4a75828275eb0.tar.bz2
gentoo-9d9b895c96872255400e584e76e4a75828275eb0.zip
games-engines/devilutionx: Bump to version 1.2.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/devilutionx/Manifest1
-rw-r--r--games-engines/devilutionx/devilutionx-1.2.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/games-engines/devilutionx/Manifest b/games-engines/devilutionx/Manifest
index a3018a86cce5..e21f9b5eae14 100644
--- a/games-engines/devilutionx/Manifest
+++ b/games-engines/devilutionx/Manifest
@@ -1,2 +1,3 @@
DIST devilutionx-1.1.0.tar.gz 2271614 BLAKE2B 8afdffafd86477bdeb62c2c3abb96d35dcccde7f7c44cb5ca5bbd8b46ae5f3998262eae4fa23f5c84a3ffdbcbdfc27cf91dc758cb69bfe24b301959085fbe31e SHA512 341e7f2e74e7af4a7b42054b58b6518c2f286f2fdcb21c5553a15912c044ea08f6c7b07a2079e7e795a5146e7a301789fe32b6fda5ff9fbec0654d886d423b38
DIST devilutionx-1.2.0.tar.gz 3571940 BLAKE2B 26001a8dc594777dbf6822c41ce89ad08e6cdff5621c04083ede1398cd12d4c4496da91e4cfed674e73c5411b2c569539a37102c4a418d552bb383a71527a4f2 SHA512 30ae94feacb9125345f877981c0e23ccbc3a0db96be6c5b1a402c7c5685b5f60f825c9dcde91dbf344b845c03b0b77358e5c656aac7869b5c450b72457da02c9
+DIST devilutionx-1.2.1.tar.gz 3573200 BLAKE2B c3055bfa8ae0a670e21561673e23277fb76e2b24d269fdd86d13510f68a0e841ec96ab06cf98739913870884d82037b5297ce168e6cba1f8795de6ea72620649 SHA512 9327b127d0ad22d640b1a13fad9bfa00ba0fc512dd7ed362a9e84a80278d84634cd039cba7c98f15425715b11a35dc6ac07d75c816c3cbc818e6ab8c4437cf18
diff --git a/games-engines/devilutionx/devilutionx-1.2.1.ebuild b/games-engines/devilutionx/devilutionx-1.2.1.ebuild
new file mode 100644
index 000000000000..01125c9e7e42
--- /dev/null
+++ b/games-engines/devilutionx/devilutionx-1.2.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Sometimes build with ninja fails.
+# Please check occasionally if we can revert back to ninja.
+# Latest known issue:
+#
+#CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake
+
+DESCRIPTION="Diablo engine for modern operating systems"
+HOMEPAGE="https://github.com/diasurgical/devilutionX"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/diasurgical/devilutionX.git"
+else
+ SRC_URI="https://github.com/diasurgical/devilutionX/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/devilutionX-${PV}"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+
+IUSE="debug lto"
+
+RDEPEND="
+ dev-libs/libsodium
+ media-fonts/sil-charis
+ media-libs/libsdl2[haptic]
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.0_pre-no_bundled_font.patch" #704508
+)
+
+DOCS=( docs/CHANGELOG.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DASAN="OFF"
+ -DDEBUG="$(usex debug)"
+ -DDISABLE_LTO="$(usex !lto)"
+ -DDIST="ON"
+ -DUBSAN="OFF"
+ )
+
+ if [[ "${PV}" != 9999 ]] ; then
+ mycmakeargs+=( -DVERSION_NUM="${PV}" )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo "In order to play the game you need to install the file"
+ einfo " diabdat.mpq"
+ einfo "from the original game CD into the following directory:"
+ einfo " \${HOME}/.local/share/diasurgical/devilution/"
+}