summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-29 13:37:21 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-29 13:37:56 +0200
commita1703822ee4d05229a2fa4b115401001ce050dca (patch)
tree3c9d32be08daacee337e093bb11a86b061c7b46d /games-engines
parentdev-libs/libpcre2: Enable pcre16 by default (diff)
downloadgentoo-a1703822ee4d05229a2fa4b115401001ce050dca.tar.gz
gentoo-a1703822ee4d05229a2fa4b115401001ce050dca.tar.bz2
gentoo-a1703822ee4d05229a2fa4b115401001ce050dca.zip
games-engines/frotz: bump to 2.53
Trivial bump. Does not come with an automated test suite but having manually run all the interactive tests provided in src/test/ using the ncurses interface, everything seems to be in order. Permission to commit in maintainers' stead granted by sam on Bugzilla. Closes: https://bugs.gentoo.org/86576 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/frotz/Manifest1
-rw-r--r--games-engines/frotz/frotz-2.53.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/games-engines/frotz/Manifest b/games-engines/frotz/Manifest
index 393de8b60e3a..6678f254461c 100644
--- a/games-engines/frotz/Manifest
+++ b/games-engines/frotz/Manifest
@@ -1 +1,2 @@
DIST frotz-2.52.tar.bz2 289109 BLAKE2B d1e97e05d1da187846c64dacdf69f34a800be97b75121dc8de63c619687ed5ccbd6b03b2391d2896a14aaad1e4f8eb51926affb92a36f1a5bad8acec91524774 SHA512 387e7a7fe0cffd40b639a306eef89a22421a4ff4a8e5dbcf96a1ef3b901744b3f75a671953ecdc17bde0d699e4756d470b61c8213c47315baa2700da92d06710
+DIST frotz-2.53.tar.bz2 375800 BLAKE2B a3d14d11540cb12ed6e5326207946e26b0b3b85e13c50e7431f3901cfb19337661b233bf29077c1efe3a9663aef6d2886bba1717c8132d68e77580692fed30d1 SHA512 e920529920a0b831b859323046aeae032b4b84ac0296d4ef35026fe8a62798cf5f9f4e255af38421aa21ad5507cd87287924daafc759c9b9d7a089ba7d77d808
diff --git a/games-engines/frotz/frotz-2.53.ebuild b/games-engines/frotz/frotz-2.53.ebuild
new file mode 100644
index 000000000000..f03a3d070289
--- /dev/null
+++ b/games-engines/frotz/frotz-2.53.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter for Z-code based text games"
+HOMEPAGE="https://661.org/proj/if/frotz/"
+SRC_URI="https://gitlab.com/DavidGriffith/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ncurses sdl sound unicode"
+REQUIRED_USE="sound? ( || ( ncurses sdl ) )"
+
+DEPEND="
+ ncurses? (
+ sys-libs/ncurses:0=[unicode?]
+ sound? (
+ media-libs/libao
+ media-libs/libmodplug
+ media-libs/libsamplerate
+ media-libs/libsndfile[-minimal]
+ media-libs/libvorbis
+ )
+ )
+ sdl? (
+ media-libs/freetype:2
+ media-libs/libpng:0=
+ media-libs/libsdl2[sound,threads,video]
+ media-libs/sdl2-mixer[mod,vorbis,wav]
+ sys-libs/zlib
+ virtual/jpeg:0=
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ emake \
+ dumb \
+ $(use ncurses && echo ncurses) \
+ $(use sdl && echo sdl) \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CURSES=$(usex unicode ncursesw ncurses) \
+ USE_UTF8=$(usex unicode yes "") \
+ SOUND_TYPE=$(usex sound ao none) \
+ PREFIX="${EPREFIX}/usr" \
+ SYSCONFDIR="${EPREFIX}/etc"
+}
+
+src_install() {
+ emake \
+ install_dumb \
+ $(use ncurses && echo install) \
+ $(use sdl && echo install_sdl) \
+ PREFIX="${EPREFIX}/usr" \
+ DESTDIR="${D}"
+
+ dodoc \
+ AUTHORS ChangeLog CONTRIBUTORS DUMB HOW_TO_PLAY README TODO \
+ doc/frotz.conf-{big,small}
+}
+
+pkg_postinst() {
+ echo
+ elog "Global config file can be installed in ${EPREFIX}/etc/frotz.conf"
+ elog "Sample config files are in ${EPREFIX}/usr/share/doc/${PF}"
+ echo
+}