summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-30 18:50:12 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-30 19:32:04 +0100
commite1e7819e118d0c4ea95de4d5d03e7b298102b37c (patch)
treec07f46d5cafa89a35929c170608e0896787c0bba /games-engines
parentwww-client/chromium: add a disclaimer regarding CHROMIUM_FORCE_CLANG (diff)
downloadgentoo-e1e7819e118d0c4ea95de4d5d03e7b298102b37c.tar.gz
gentoo-e1e7819e118d0c4ea95de4d5d03e7b298102b37c.tar.bz2
gentoo-e1e7819e118d0c4ea95de4d5d03e7b298102b37c.zip
games-engines/solarus: migrate to lua-single.eclass
Simple enough. upstream build scripts explicitly support only LuaJIT and Lua5.1. Closes: https://bugs.gentoo.org/752687 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/solarus/solarus-1.3.1-r100.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-engines/solarus/solarus-1.3.1-r100.ebuild b/games-engines/solarus/solarus-1.3.1-r100.ebuild
new file mode 100644
index 000000000000..7d865fec4101
--- /dev/null
+++ b/games-engines/solarus/solarus-1.3.1-r100.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 luajit )
+
+inherit cmake lua-single
+
+DESCRIPTION="An open-source Zelda-like 2D game engine"
+HOMEPAGE="https://www.solarus-games.org/"
+SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}
+ dev-games/physfs
+ media-libs/libmodplug
+ >=media-libs/libsdl2-2.0.1[X,joystick,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ >=media-libs/sdl2-ttf-2.0.12"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSOLARUS_INSTALL_DESTINATION="/usr/bin"
+ -DSOLARUS_USE_LUAJIT="$(usex lua_single_target_luajit)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ cd doc || die
+ doxygen || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ doman solarus.6
+ use doc && dodoc -r doc/${PV%.*}/html/*
+}