summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-14 17:06:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-14 17:19:51 -0400
commitfdf3a6ff7d8be2cb8ec2d7aa5dafbf4222d4bb73 (patch)
tree6e303495215e90b45fbc88f94ed8f9443a2f9d06 /games-engines
parentgames-emulation/snes9x: drop 1.61 (diff)
downloadgentoo-fdf3a6ff7d8be2cb8ec2d7aa5dafbf4222d4bb73.tar.gz
gentoo-fdf3a6ff7d8be2cb8ec2d7aa5dafbf4222d4bb73.tar.bz2
gentoo-fdf3a6ff7d8be2cb8ec2d7aa5dafbf4222d4bb73.zip
games-engines/devilutionx: drop 1.4.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/devilutionx/Manifest1
-rw-r--r--games-engines/devilutionx/devilutionx-1.4.1.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/games-engines/devilutionx/Manifest b/games-engines/devilutionx/Manifest
index 4515dbd20298..cbd3474c99a4 100644
--- a/games-engines/devilutionx/Manifest
+++ b/games-engines/devilutionx/Manifest
@@ -1,2 +1 @@
-DIST devilutionx-1.4.1.tar.xz 19679968 BLAKE2B 51ae007d5d1dce25a9af20b98017826534d835c2a74bfcd78cb4fb3c8e86b4e2e55a302e0412cbbcff8f931ad33a2baab806199769660351f31cc49fa91814b6 SHA512 9709600395abfd697bc45757bd2cf3e5cf0e07e2c55c86a48a73e9f52003c274724e26306b4fcb36c2eda0776c51dbab96599c0d14744244c8c037fd5dd14263
DIST devilutionx-1.5.0.tar.xz 21951316 BLAKE2B efc6d3539eed25f917d30f3a858903952068bf4d4c66b0cd39f1a86ce3f98d9d67a8bce3a2467fa22e91bd2f552fbb593b602273e163422ab5f133133d513060 SHA512 df4998a86203372b82cb3be0348a1555ea95127a22ef050fed068215fd2223550f2b64364d83a58f829398169a29a5990d4332dc7f0adec6316f3a6c8e280ccb
diff --git a/games-engines/devilutionx/devilutionx-1.4.1.ebuild b/games-engines/devilutionx/devilutionx-1.4.1.ebuild
deleted file mode 100644
index e7608abb497b..000000000000
--- a/games-engines/devilutionx/devilutionx-1.4.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-DESCRIPTION="Diablo engine for modern operating systems"
-HOMEPAGE="https://github.com/diasurgical/devilutionX/"
-SRC_URI="https://github.com/diasurgical/devilutionX/releases/download/${PV}/devilutionx-src.tar.xz -> ${P}.tar.xz"
-S="${WORKDIR}/${PN}-src-${PV}-5ad792133"
-
-LICENSE="Unlicense CC-BY-4.0 GPL-2+ LGPL-2.1+ MIT OFL-1.1 zerotier? ( BSL-1.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug +sodium test zerotier"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/bzip2:=
- dev-libs/libfmt:=
- media-libs/libsdl2[haptic,joystick,opengl,video]
- media-libs/sdl2-image[png]
- sys-libs/zlib:=
- media-libs/sdl_audiolib
- sodium? ( dev-libs/libsodium:= )"
-DEPEND="
- ${RDEPEND}
- dev-cpp/asio
- dev-cpp/simpleini
- test? ( dev-cpp/gtest )"
-BDEPEND="sys-devel/gettext"
-
-src_prepare() {
- cmake_src_prepare
-
- # use system asio
- echo 'add_library(asio INTERFACE)' > 3rdParty/asio/CMakeLists.txt || die
-
- # ensure system copies are used
- rm -r dist/{asio,simpleini,sdl_audiolib}-src || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test)
- -DCCACHE_PROGRAM=OFF #813768
- -DDEBUG=$(usex debug)
- -DDISABLE_LTO=ON # let CFLAGS control this
- -DDISABLE_ZERO_TIER=$(usex !zerotier)
- -DPACKET_ENCRYPTION=$(usex sodium)
- -DPIE=ON
- )
-
- cmake_src_configure
-}
-
-src_install() {
- local DOCS=( Packaging/nix/README.txt docs/*.md )
- cmake_src_install
-
- rm "${ED}"/usr/share/diasurgical/devilutionx/README.txt || die
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "In order to play the game, you will need to copy the following data file"
- elog "from the original game, and optionally the hellfire expansion files:"
- elog " - DIABDAT.MPQ"
- elog " - hellfire.mpq hfmonk.mpq hfmusic.mpq hfvoice.mpq"
- elog "to ~/.local/share/diasurgical/devilution/"
- elog
- elog "See ${EROOT}/usr/share/doc/${PF}/README.txt* for details."
- fi
-}