summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-11-28 23:16:10 +1100
committerSam James <sam@gentoo.org>2023-01-28 03:18:20 +0000
commitd5e23a0191e453f77d7130aee6e3d9eb373f456d (patch)
tree13dc4b66b2a3c3c1468f0542e3a8eda6e1e406c5 /games-fps/alephone-infinity/alephone-infinity-20221126.ebuild
parentgames-fps/alephone-durandal: drop 20220115 (diff)
downloadgentoo-d5e23a0191e453f77d7130aee6e3d9eb373f456d.tar.gz
gentoo-d5e23a0191e453f77d7130aee6e3d9eb373f456d.tar.bz2
gentoo-d5e23a0191e453f77d7130aee6e3d9eb373f456d.zip
games-fps/alephone-infinity: add 20221126
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps/alephone-infinity/alephone-infinity-20221126.ebuild')
-rw-r--r--games-fps/alephone-infinity/alephone-infinity-20221126.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-fps/alephone-infinity/alephone-infinity-20221126.ebuild b/games-fps/alephone-infinity/alephone-infinity-20221126.ebuild
new file mode 100644
index 000000000000..4c0369226bad
--- /dev/null
+++ b/games-fps/alephone-infinity/alephone-infinity-20221126.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon Infinity"
+HOMEPAGE="https://alephone.lhowon.org/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/MarathonInfinity-${PV}-Data.zip"
+S="${WORKDIR}/Marathon Infinity"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="infinity"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}