summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-09-05 21:06:37 +1000
committerSam James <sam@gentoo.org>2022-09-21 01:04:15 +0100
commita6342eae7590b9d527023d4a983c29e2b08dc149 (patch)
tree1c027ec96356e6cc25233a74d6b924909a88f203 /games-fps/alephone/alephone-20220115.ebuild
parentgames-fps/alephone: add additional speex? dependency (diff)
downloadgentoo-a6342eae7590b9d527023d4a983c29e2b08dc149.tar.gz
gentoo-a6342eae7590b9d527023d4a983c29e2b08dc149.tar.bz2
gentoo-a6342eae7590b9d527023d4a983c29e2b08dc149.zip
games-fps/alephone: override AR in src_compile
Closes: https://bugs.gentoo.org/867622 Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/27152 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps/alephone/alephone-20220115.ebuild')
-rw-r--r--games-fps/alephone/alephone-20220115.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/games-fps/alephone/alephone-20220115.ebuild b/games-fps/alephone/alephone-20220115.ebuild
index 3b71a7f7c6ec..3fc299106b8f 100644
--- a/games-fps/alephone/alephone-20220115.ebuild
+++ b/games-fps/alephone/alephone-20220115.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools optfeature prefix xdg
+inherit autotools optfeature prefix toolchain-funcs xdg
DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
HOMEPAGE="http://source.bungie.org/"
@@ -75,6 +75,11 @@ src_configure() {
$(use_with upnp miniupnpc)
}
+src_compile() {
+ tc-export AR
+ default
+}
+
src_install() {
default
prefixify_ro "${FILESDIR}"/${PN}.sh