summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-02-06 17:41:44 -0600
committerAustin English <wizardedit@gentoo.org>2017-02-06 18:51:24 -0600
commit1c2f35d069049c89331abfbc69aab52790537ded (patch)
tree009829baaad97ffb43654d8bbab5577930061f2f /games-fps/avp
parentgames-fps/alephone: remove deprecated games eclass (diff)
downloadgentoo-1c2f35d069049c89331abfbc69aab52790537ded.tar.gz
gentoo-1c2f35d069049c89331abfbc69aab52790537ded.tar.bz2
gentoo-1c2f35d069049c89331abfbc69aab52790537ded.zip
games-fps/avp: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-fps/avp')
-rw-r--r--games-fps/avp/avp-20150214-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-fps/avp/avp-20150214-r1.ebuild b/games-fps/avp/avp-20150214-r1.ebuild
new file mode 100644
index 000000000000..889aedc327d1
--- /dev/null
+++ b/games-fps/avp/avp-20150214-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils cmake-utils
+
+DESCRIPTION="Linux port of Aliens vs Predator"
+HOMEPAGE="http://www.icculus.org/avp/"
+SRC_URI="http://www.icculus.org/avp/files/${P}.tar.gz"
+
+LICENSE="AvP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[video,joystick,opengl]
+ media-libs/openal"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CMAKE_BUILD_TYPE=Release
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ -DSDL_TYPE=SDL
+ -DOPENGL_TYPE=OPENGL
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/${PN}"
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "Please follow the instructions in /usr/share/doc/${PF}"
+ elog "to install the rest of the game."
+}