summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-15 19:49:30 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-15 19:49:30 +0100
commita95a36e8445946da1a12728f8929bdcd01a8506b (patch)
tree18032db9f1e227a1e56fade9da14a990aa9751d6 /games-fps/avp
parentdev-python/dogpile-cache: Bump to 1.1.0 (diff)
downloadgentoo-a95a36e8445946da1a12728f8929bdcd01a8506b.tar.gz
gentoo-a95a36e8445946da1a12728f8929bdcd01a8506b.tar.bz2
gentoo-a95a36e8445946da1a12728f8929bdcd01a8506b.zip
games-fps/avp: Port to EAPI 7
* Restrict redistribution * Fix -fno-common Closes: https://bugs.gentoo.org/694940 Closes: https://bugs.gentoo.org/708416 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-fps/avp')
-rw-r--r--games-fps/avp/avp-20150214-r1.ebuild29
-rw-r--r--games-fps/avp/files/avp-20150214-fno-common.patch22
2 files changed, 34 insertions, 17 deletions
diff --git a/games-fps/avp/avp-20150214-r1.ebuild b/games-fps/avp/avp-20150214-r1.ebuild
index 7a41b588eaad..fb38321a71fb 100644
--- a/games-fps/avp/avp-20150214-r1.ebuild
+++ b/games-fps/avp/avp-20150214-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils cmake-utils
+EAPI=7
+
+inherit cmake
DESCRIPTION="Linux port of Aliens vs Predator"
HOMEPAGE="http://www.icculus.org/avp/"
@@ -11,36 +12,30 @@ SRC_URI="http://www.icculus.org/avp/files/${P}.tar.gz"
LICENSE="AvP"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+RESTRICT="bindist mirror"
RDEPEND="
media-libs/libsdl[video,joystick,opengl]
media-libs/openal"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-CMAKE_BUILD_TYPE=Release
+PATCHES=( "${FILESDIR}"/avp-20150214-fno-common.patch )
src_configure() {
local mycmakeargs=(
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
-DSDL_TYPE=SDL
-DOPENGL_TYPE=OPENGL
)
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
+ cmake_src_configure
}
src_install() {
- dobin "${BUILD_DIR}/${PN}"
- dodoc README
+ dobin "${BUILD_DIR}"/avp
+ einstalldocs
}
pkg_postinst() {
- elog "Please follow the instructions in /usr/share/doc/${PF}"
+ elog "Please follow the instructions in ${EROOT}/usr/share/doc/${PF}"
elog "to install the rest of the game."
}
diff --git a/games-fps/avp/files/avp-20150214-fno-common.patch b/games-fps/avp/files/avp-20150214-fno-common.patch
new file mode 100644
index 000000000000..0f25b1cf267f
--- /dev/null
+++ b/games-fps/avp/files/avp-20150214-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/src/avp/win95/d3d_render.cpp
++++ b/src/avp/win95/d3d_render.cpp
+@@ -2990,7 +2990,7 @@
+ //#define WATER_POLY_SCALE 256
+ int MeshXScale;
+ int MeshZScale;
+-int WaterFallBase;
++extern int WaterFallBase;
+ void PostLandscapeRendering(void)
+ {
+ extern int NumOnScreenBlocks;
+--- a/src/opengl.c
++++ b/src/opengl.c
+@@ -2796,7 +2796,7 @@
+
+ int MeshXScale;
+ int MeshZScale;
+-int WaterFallBase;
++extern int WaterFallBase;
+
+ int WaterXOrigin;
+ int WaterZOrigin;