summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-25 04:04:15 +0100
committerSam James <sam@gentoo.org>2021-07-31 01:17:34 +0100
commitb04be9138de567f84dba361311d83a3c2bb96bc5 (patch)
tree56d4f1954c579ee2477d3ff84f6b8c2985c3dbf3 /games-fps/chocolate-doom
parentapp-admin/pass: [QA] unconditionally install completion files (diff)
downloadgentoo-b04be9138de567f84dba361311d83a3c2bb96bc5.tar.gz
gentoo-b04be9138de567f84dba361311d83a3c2bb96bc5.tar.bz2
gentoo-b04be9138de567f84dba361311d83a3c2bb96bc5.zip
games-fps/chocolate-doom: [QA] unconditionally install completion files
QA policy [0] says that we don't conditionalise installation of small files. It's a wasteful rebuild and inconsistent across packages for when users desire completions to be available. [0] https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0301 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps/chocolate-doom')
-rw-r--r--games-fps/chocolate-doom/chocolate-doom-3.0.1-r1.ebuild (renamed from games-fps/chocolate-doom/chocolate-doom-3.0.1.ebuild)11
1 files changed, 6 insertions, 5 deletions
diff --git a/games-fps/chocolate-doom/chocolate-doom-3.0.1.ebuild b/games-fps/chocolate-doom/chocolate-doom-3.0.1-r1.ebuild
index 13647f2153ff..02a5356a9c32 100644
--- a/games-fps/chocolate-doom/chocolate-doom-3.0.1.ebuild
+++ b/games-fps/chocolate-doom/chocolate-doom-3.0.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
inherit autotools prefix python-any-r1 xdg
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz
LICENSE="BSD GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion doc libsamplerate +midi png vorbis"
+IUSE="doc libsamplerate +midi png vorbis"
DEPEND="
media-libs/libsdl2[video]
@@ -24,8 +24,9 @@ DEPEND="
libsamplerate? ( media-libs/libsamplerate )
png? ( media-libs/libpng:= )"
RDEPEND="${DEPEND}"
+# ${PYTHON_DEPS} for bash-completion
BDEPEND="
- bash-completion? ( ${PYTHON_DEPS} )
+ ${PYTHON_DEPS}
doc? ( ${PYTHON_DEPS} )"
S="${WORKDIR}/${PN}-${P}"
@@ -69,7 +70,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable bash-completion) \
+ --enable-bash-completion \
$(use_enable doc) \
--disable-fonts \
--disable-icons \