summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 00:09:41 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 01:48:16 -0500
commit4cf1f42847ddbe6c86c2cf927a8b28844d70c6e3 (patch)
treea680ce94a991b48c31699c5dd1749991b49581ff /games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild
parentgames-fps/doom3-ducttape: EAPI=5 (diff)
downloadgentoo-4cf1f42847ddbe6c86c2cf927a8b28844d70c6e3.tar.gz
gentoo-4cf1f42847ddbe6c86c2cf927a8b28844d70c6e3.tar.bz2
gentoo-4cf1f42847ddbe6c86c2cf927a8b28844d70c6e3.zip
games-fps/doom3-ducttape: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild')
-rw-r--r--games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild b/games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild
new file mode 100644
index 000000000000..95896973c82e
--- /dev/null
+++ b/games-fps/doom3-ducttape/doom3-ducttape-0007.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MOD_DESC="sticks flashlights to your machinegun and shotgun"
+MOD_NAME="Duct Tape"
+MOD_DIR="ducttape"
+
+inherit games games-mods
+
+HOMEPAGE="http://ducttape.glenmurphy.com/"
+SRC_URI="http://ducttape.glenmurphy.com/ducttape${PV}.zip"
+
+LICENSE="freedist"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+
+src_unpack() {
+ mkdir ${MOD_DIR} || die
+ cd ${MOD_DIR} || die
+ unpack ${A}
+}
+
+src_prepare() {
+ rm -f ${MOD_DIR}/pak002.pk4 || die # for doom3-roe
+}
+
+pkg_postinst() {
+ games-mods_pkg_postinst
+
+ elog "To use old saved games with this mod, run:"
+ elog " mkdir -p ~/.doom3/ducttape"
+ elog " cp -r ~/.doom3/base/savegames ~/.doom3/ducttape"
+}