summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 19:04:05 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 19:13:13 +0200
commit7537862d4fee658321df54d024fad58ac0eb04c1 (patch)
treef57118fb4cc41f3505602382b1cc71b25c8a2fbb /games-fps/doomsday/doomsday-2.0.3.ebuild
parentgames-fps/doom-data: Drop old (diff)
downloadgentoo-7537862d4fee658321df54d024fad58ac0eb04c1.tar.gz
gentoo-7537862d4fee658321df54d024fad58ac0eb04c1.tar.bz2
gentoo-7537862d4fee658321df54d024fad58ac0eb04c1.zip
games-fps/doomsday: Version bump (#617908)
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-fps/doomsday/doomsday-2.0.3.ebuild')
-rw-r--r--games-fps/doomsday/doomsday-2.0.3.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/games-fps/doomsday/doomsday-2.0.3.ebuild b/games-fps/doomsday/doomsday-2.0.3.ebuild
new file mode 100644
index 000000000000..8e474baec7fa
--- /dev/null
+++ b/games-fps/doomsday/doomsday-2.0.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 readme.gentoo-r1 cmake-utils
+
+DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
+HOMEPAGE="http://www.dengine.net"
+SRC_URI="https://downloads.sourceforge.net/project/deng/Doomsday%20Engine/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="fluidsynth openal +doom demo freedoom heretic hexen tools fmod"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ demo? ( doom ) freedoom? ( doom )
+"
+
+RDEPEND="
+ >=dev-util/cmake-3.1
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtgui:5[-gles2]
+ dev-qt/qtcore:5
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/assimp
+ fmod? ( media-libs/fmod )
+ fluidsynth? ( media-sound/fluidsynth )
+ openal? ( media-libs/openal )
+ tools? ( sys-libs/ncurses:0 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+PDEPEND="
+ demo? ( games-fps/doom-data )
+ freedoom? ( games-fps/freedoom )
+"
+
+S="${WORKDIR}/${P}/${PN}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You need to copy Doom, Doom 2, Chex Quest, Heretic, Hexen, HexenDD,
+and Doom64 wads to a folder of your choice. Then configure in game
+engine where that folder is. This is different than old versions,
+which had centralized launchers for each game, and required the
+files to be in a specific place
+"
+
+internal_src_configure() {
+ export QT_SELECT=qt5
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DDENG_ASSIMP_EMBEDDED=off
+ )
+ cmake-utils_src_configure
+}
+
+src_configure() {
+ python_foreach_impl internal_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}