summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-09-10 19:33:09 +0900
committerJames Le Cuirot <chewi@gentoo.org>2019-09-19 23:08:31 +0100
commitcc51ed57d5b277bf9d2df5af62df28265839357b (patch)
tree5f58e0cb64681bb9a6a98aeb7b86bb9d7f82099e /games-fps/gzdoom/files
parentprofiles: Last-rite games-action/minetest_game (diff)
downloadgentoo-cc51ed57d5b277bf9d2df5af62df28265839357b.tar.gz
gentoo-cc51ed57d5b277bf9d2df5af62df28265839357b.tar.bz2
gentoo-cc51ed57d5b277bf9d2df5af62df28265839357b.zip
games-fps/gzdoom: Bump to version 4.2.1
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12895 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps/gzdoom/files')
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch36
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch34
2 files changed, 70 insertions, 0 deletions
diff --git a/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch b/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch
new file mode 100644
index 000000000000..c74d08a24a47
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch
@@ -0,0 +1,36 @@
+From 1e09b211a000c649aae6eea736647daa650141bc Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Sat, 31 Aug 2019 21:23:23 +0900
+Subject: [PATCH] Introduce the BUILD_NONFREE option
+
+This allow users to disable building nonfree components (brightmaps.pk3
+and game_support.pk3) if they so desire.
+---
+ CMakeLists.txt | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7860358ef..23d317f42 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -404,10 +404,15 @@ add_subdirectory( libraries/lzma )
+ add_subdirectory( tools )
+ add_subdirectory( libraries/dumb )
+ add_subdirectory( libraries/gdtoa )
++
+ add_subdirectory( wadsrc )
+-add_subdirectory( wadsrc_bm )
+ add_subdirectory( wadsrc_lights )
+-add_subdirectory( wadsrc_extra )
++option (BUILD_NONFREE "Build nonfree components" ON)
++if( BUILD_NONFREE )
++ add_subdirectory( wadsrc_bm )
++ add_subdirectory( wadsrc_extra )
++endif()
++
+ add_subdirectory( src )
+
+ if( NOT CMAKE_CROSSCOMPILING )
+--
+2.23.0
+
diff --git a/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch b/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch
new file mode 100644
index 000000000000..1fe0b99d9a8e
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch
@@ -0,0 +1,34 @@
+From 2d1c7ba17cac3ccd201e77ad01a9dd06ab22cb2e Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Thu, 13 Jun 2019 18:01:08 +0900
+Subject: [PATCH] Install soundfonts and WOPL/WOPN banks
+
+The INSTALL_SOUNDFONT_PATH cache entry is used to configure the
+installation directory.
+---
+ src/CMakeLists.txt | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 0bb16f39e..4ff15062d 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1451,6 +1451,15 @@ add_custom_command(TARGET zdoom POST_BUILD
+ ${CMAKE_SOURCE_DIR}/fm_banks/gs-by-papiezak-and-sneakernets.wopn $<TARGET_FILE_DIR:zdoom>/fm_banks/gs-by-papiezak-and-sneakernets.wopn
+ )
+
++if( WIN32 )
++ set( INSTALL_SOUNDFONT_PATH . CACHE STRING "Directory where soundfonts and WOPL/WOPN banks will be placed during install." )
++else()
++ set( INSTALL_SOUNDFONT_PATH share/games/doom CACHE STRING "Directory where soundfonts and WOPL/WOPN banks will be placed during install." )
++endif()
++install(FILES "${PROJECT_BINARY_DIR}/soundfonts" "${PROJECT_BINARY_DIR}/fm_banks"
++ DESTINATION ${INSTALL_SOUNDFONT_PATH}
++ COMPONENT "Soundfont resources")
++
+ if( CMAKE_COMPILER_IS_GNUCXX )
+ # GCC misoptimizes this file
+ set_source_files_properties( oplsynth/fmopl.cpp PROPERTIES COMPILE_FLAGS "-fno-tree-dominator-opts -fno-tree-fre" )
+--
+2.21.0
+