summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-08 16:29:54 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-08 16:29:54 -0500
commit9e2a01c4881b67200d0a43ab7d6f147d6e5ac2aa (patch)
treeeee761fd7ead0e24155a60891fae81b05f7500ea /games-fps/openarena/files
parentgames-fps/unreal-tournament: drop vulnerable (diff)
downloadgentoo-9e2a01c4881b67200d0a43ab7d6f147d6e5ac2aa.tar.gz
gentoo-9e2a01c4881b67200d0a43ab7d6f147d6e5ac2aa.tar.bz2
gentoo-9e2a01c4881b67200d0a43ab7d6f147d6e5ac2aa.zip
games-fps/quake3*: drop vulnerable pkgs
Closes: https://bugs.gentoo.org/420783 Closes: https://bugs.gentoo.org/606696 Closes: https://bugs.gentoo.org/627236 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'games-fps/openarena/files')
-rw-r--r--games-fps/openarena/files/openarena-0.8.8-makefile.patch36
-rw-r--r--games-fps/openarena/files/openarena-0.8.8-unbundling.patch104
2 files changed, 0 insertions, 140 deletions
diff --git a/games-fps/openarena/files/openarena-0.8.8-makefile.patch b/games-fps/openarena/files/openarena-0.8.8-makefile.patch
deleted file mode 100644
index d72bbe79b29d..000000000000
--- a/games-fps/openarena/files/openarena-0.8.8-makefile.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Thu May 17 23:34:20 UTC 2012
-Subject: flags, arch
-
---- openarena-engine-source-0.8.8/Makefile
-+++ openarena-engine-source-0.8.8/Makefile
-@@ -73,6 +73,10 @@
-
- ifndef ARCH
- ARCH=$(COMPILE_ARCH)
-+else
-+ ifeq ($(ARCH),amd64)
-+ ARCH=x86_64
-+ endif
- endif
- export ARCH
-
-@@ -263,8 +267,7 @@
- endif
- endif
-
-- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
-- -pipe -DUSE_ICON
-+ BASE_CFLAGS = -fno-strict-aliasing -DUSE_ICON -I.
- CLIENT_CFLAGS = $(SDL_CFLAGS)
- SERVER_CFLAGS =
-
-@@ -335,7 +338,7 @@
- THREAD_LIBS=-lpthread
- LIBS=-ldl -lm
-
-- CLIENT_LIBS=$(SDL_LIBS) -lGL
-+ CLIENT_LIBS=$(SDL_LIBS) -lGL -ljpeg
-
- ifeq ($(USE_OPENAL),1)
- ifneq ($(USE_OPENAL_DLOPEN),1) \ No newline at end of file
diff --git a/games-fps/openarena/files/openarena-0.8.8-unbundling.patch b/games-fps/openarena/files/openarena-0.8.8-unbundling.patch
deleted file mode 100644
index b2c872f34cbd..000000000000
--- a/games-fps/openarena/files/openarena-0.8.8-unbundling.patch
+++ /dev/null
@@ -1,104 +0,0 @@
---- openarena-engine-source-0.8.8/Makefile
-+++ openarena-engine-source-0.8.8/Makefile
-@@ -1406,41 +1406,6 @@
- $(B)/client/l_script.o \
- $(B)/client/l_struct.o \
- \
-- $(B)/client/jcapimin.o \
-- $(B)/client/jcapistd.o \
-- $(B)/client/jccoefct.o \
-- $(B)/client/jccolor.o \
-- $(B)/client/jcdctmgr.o \
-- $(B)/client/jchuff.o \
-- $(B)/client/jcinit.o \
-- $(B)/client/jcmainct.o \
-- $(B)/client/jcmarker.o \
-- $(B)/client/jcmaster.o \
-- $(B)/client/jcomapi.o \
-- $(B)/client/jcparam.o \
-- $(B)/client/jcphuff.o \
-- $(B)/client/jcprepct.o \
-- $(B)/client/jcsample.o \
-- $(B)/client/jdapimin.o \
-- $(B)/client/jdapistd.o \
-- $(B)/client/jdatasrc.o \
-- $(B)/client/jdcoefct.o \
-- $(B)/client/jdcolor.o \
-- $(B)/client/jddctmgr.o \
-- $(B)/client/jdhuff.o \
-- $(B)/client/jdinput.o \
-- $(B)/client/jdmainct.o \
-- $(B)/client/jdmarker.o \
-- $(B)/client/jdmaster.o \
-- $(B)/client/jdpostct.o \
-- $(B)/client/jdsample.o \
-- $(B)/client/jdtrans.o \
-- $(B)/client/jerror.o \
-- $(B)/client/jfdctflt.o \
-- $(B)/client/jidctflt.o \
-- $(B)/client/jmemmgr.o \
-- $(B)/client/jmemnobs.o \
-- $(B)/client/jutils.o \
- \
- $(B)/client/tr_animation.o \
- $(B)/client/tr_backend.o \
---- openarena-engine-source-0.8.8/code/renderer/tr_image_jpg.c
-+++ openarena-engine-source-0.8.8/code/renderer/tr_image_jpg.c
-@@ -31,7 +31,7 @@
- */
-
- #define JPEG_INTERNALS
--#include "../jpeg-6b/jpeglib.h"
-+#include <jpeglib.h>
-
- void R_LoadJPG( const char *filename, unsigned char **pic, int *width, int *height ) {
- /* This struct contains the JPEG decompression parameters and pointers to
-@@ -131,7 +131,10 @@
- }
-
- memcount = pixelcount * 4;
-- row_stride = cinfo.output_width * cinfo.output_components;
-+ if (3 == cinfo.output_components)
-+ row_stride = cinfo.output_width * 4;
-+ else
-+ row_stride = cinfo.output_width * cinfo.output_components;
-
- out = ri.Malloc(memcount);
-
-@@ -144,14 +147,26 @@
- /* Here we use the library's state variable cinfo.output_scanline as the
- * loop counter, so that we don't have to keep track ourselves.
- */
-+ buf = out;
- while (cinfo.output_scanline < cinfo.output_height) {
- /* jpeg_read_scanlines expects an array of pointers to scanlines.
- * Here the array is only one element long, but you could ask for
- * more than one scanline at a time if that's more convenient.
- */
-- buf = ((out+(row_stride*cinfo.output_scanline)));
- buffer = &buf;
- (void) jpeg_read_scanlines(&cinfo, buffer, 1);
-+ if (3 == cinfo.output_components) {
-+ /* turn RGB into RGBA */
-+ int ioffset = cinfo.output_width * 3 - 1;
-+ int ooffset = cinfo.output_width * 4 - 1;
-+ do {
-+ buf[ooffset--] = 255;
-+ buf[ooffset--] = buf[ioffset--];
-+ buf[ooffset--] = buf[ioffset--];
-+ buf[ooffset--] = buf[ioffset--];
-+ } while (ioffset > 0);
-+ }
-+ buf += row_stride;
- }
-
- buf = out;
-@@ -176,7 +191,7 @@
- buf[--dindex] = greyshade;
- } while(sindex);
- }
-- else
-+ else if (4 == cinfo.output_components)
- {
- // clear all the alphas to 255
- int i; \ No newline at end of file