summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-08-18 07:42:43 +0900
committerIonen Wolkens <ionen@gentoo.org>2021-08-27 05:30:08 -0400
commitc22715614a24c3347d7161a221b943976b7d8c07 (patch)
tree2e16fd3645eca80d2d5b696e9ef391dc46318ccc /games-fps/prboom-plus
parentgames-action/xpilot: EAPI8, minor improvements (diff)
downloadgentoo-c22715614a24c3347d7161a221b943976b7d8c07.tar.gz
gentoo-c22715614a24c3347d7161a221b943976b7d8c07.tar.bz2
gentoo-c22715614a24c3347d7161a221b943976b7d8c07.zip
games-fps/prboom-plus: Bump to version 2.6.1
Closes: https://bugs.gentoo.org/808797 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22046 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-fps/prboom-plus')
-rw-r--r--games-fps/prboom-plus/Manifest1
-rw-r--r--games-fps/prboom-plus/files/prboom-plus-2.6.1-Guard-OpenGL-call-in-D_Display-with-GL_DOOM.patch28
-rw-r--r--games-fps/prboom-plus/prboom-plus-2.6.1.ebuild66
3 files changed, 95 insertions, 0 deletions
diff --git a/games-fps/prboom-plus/Manifest b/games-fps/prboom-plus/Manifest
index e2d5bed539ea..fc0ddfcd9b98 100644
--- a/games-fps/prboom-plus/Manifest
+++ b/games-fps/prboom-plus/Manifest
@@ -1 +1,2 @@
+DIST prboom-plus-2.6.1.tar.gz 1555792 BLAKE2B accb919039b966952340a18b3a37b9c2401a20c1f9562829ba531bf4dafc5e876d7d1212e9ba58886c7469a86b3170c48973cbd8af8ab03d1f2d685813c39607 SHA512 6ae628a453930d4fe3901d186a7c450276d023db6b38e678463f52d463a697819cea1022510030f7405bee8244c3dec04d00741fee8de839775e6e0965f0df39
DIST prboom-plus-2.6.tar.gz 1526732 BLAKE2B 00c0eeb0dfb5a99a427c986e557b6616e69be3b98373582c3aa54585136e3a16b67c0176faec59ebc011112bc8764da78b34215ae4c00b490f12820b26704e45 SHA512 c2f8c6895683ee22d729ad2c9dc10bd821e5bdb55d75b88b4c6db25b8f3604370d18285677660c82761912a159b0c1068a6fcf1c8333e20d849fa1087a74800f
diff --git a/games-fps/prboom-plus/files/prboom-plus-2.6.1-Guard-OpenGL-call-in-D_Display-with-GL_DOOM.patch b/games-fps/prboom-plus/files/prboom-plus-2.6.1-Guard-OpenGL-call-in-D_Display-with-GL_DOOM.patch
new file mode 100644
index 000000000000..78a0285703f4
--- /dev/null
+++ b/games-fps/prboom-plus/files/prboom-plus-2.6.1-Guard-OpenGL-call-in-D_Display-with-GL_DOOM.patch
@@ -0,0 +1,28 @@
+From eca393ffd3c05279150a29e104953c0234a59736 Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Fri, 27 Aug 2021 12:06:45 +0900
+Subject: [PATCH] Guard OpenGL call in D_Display() with GL_DOOM
+
+Fixes: https://github.com/coelckers/prboom-plus/issues/382
+---
+ prboom2/src/d_main.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/prboom2/src/d_main.c b/prboom2/src/d_main.c
+index 16a9efc2..4fe97465 100644
+--- a/prboom2/src/d_main.c
++++ b/prboom2/src/d_main.c
+@@ -395,8 +395,10 @@ void D_Display (fixed_t frac)
+ R_DrawViewBorder();
+ HU_Drawer();
+
++#ifdef GL_DOOM
+ if (V_GetMode() == VID_MODEGL)
+ gld_ProcessExtraAlpha();
++#endif
+ }
+
+ isborderstate = isborder;
+--
+2.33.0
+
diff --git a/games-fps/prboom-plus/prboom-plus-2.6.1.ebuild b/games-fps/prboom-plus/prboom-plus-2.6.1.ebuild
new file mode 100644
index 000000000000..4dbc0b9a4876
--- /dev/null
+++ b/games-fps/prboom-plus/prboom-plus-2.6.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg
+
+DESCRIPTION="An enhanced clone of the classic first-person shooter Doom"
+HOMEPAGE="https://github.com/coelckers/prboom-plus/"
+SRC_URI="http://deb.debian.org/debian/pool/main/p/prboom-plus/${PN}_${PV}um.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-3+ BSD BSD-2 BSD-with-disclosure CC-BY-3.0 CC0-1.0 LGPL-2.1+ MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dumb fluidsynth mad net +opengl +pcre portmidi sdl2-image +sdl2-mixer server vorbis zlib"
+REQUIRED_USE="server? ( net )"
+
+DEPEND="
+ media-libs/libsdl2[opengl?,joystick,sound,video]
+ alsa? ( media-libs/alsa-lib:= )
+ dumb? ( media-libs/dumb:= )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ mad? ( media-libs/libmad )
+ net? ( media-libs/sdl2-net )
+ pcre? ( dev-libs/libpcre:3 )
+ portmidi? ( media-libs/portmidi )
+ sdl2-image? ( media-libs/sdl2-image )
+ sdl2-mixer? ( media-libs/sdl2-mixer[midi] )
+ vorbis? ( media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}um/prboom2"
+
+src_prepare() {
+ eapply -p2 "${FILESDIR}/${P}-Guard-OpenGL-call-in-D_Display-with-GL_DOOM.patch"
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_GL="$(usex opengl)"
+ -DWITH_IMAGE="$(usex sdl2-image)"
+ -DWITH_MIXER="$(usex sdl2-mixer)"
+ -DWITH_NET="$(usex net)"
+ -DWITH_PCRE="$(usex pcre)"
+ -DWITH_ZLIB="$(usex zlib)"
+ -DWITH_MAD="$(usex mad)"
+ -DWITH_FLUIDSYNTH="$(usex fluidsynth)"
+ -DWITH_DUMB="$(usex dumb)"
+ -DWITH_VORBISFILE="$(usex vorbis)"
+ -DWITH_PORTMIDI="$(usex portmidi)"
+ -DWITH_ALSA="$(usex alsa)"
+ -DDOOMWADDIR="${EPREFIX}/usr/share/doom"
+ -DPRBOOMDATADIR="${EPREFIX}/usr/share/${PF}"
+ -DWAD_DATA_PATH="${EPREFIX}/usr/share/doom"
+ -DBUILD_SERVER="$(usex server)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ doicon -s scalable ICONS/${PN}.svg
+ domenu ICONS/${PN}.desktop
+ cmake_src_install
+}