summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/ut2003
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/ut2003')
-rw-r--r--games-fps/ut2003/Manifest1
-rw-r--r--games-fps/ut2003/metadata.xml8
-rw-r--r--games-fps/ut2003/ut2003-2225-r4.ebuild100
3 files changed, 109 insertions, 0 deletions
diff --git a/games-fps/ut2003/Manifest b/games-fps/ut2003/Manifest
new file mode 100644
index 000000000000..5ae070273bad
--- /dev/null
+++ b/games-fps/ut2003/Manifest
@@ -0,0 +1 @@
+DIST ut2003lnx_patch2225.tar.tar 10039316 SHA256 0c2d851e39b4491698f6fb3aefb9bf83340de85085f3b670d93a8cba29aefec3 SHA512 3c44b6254b2b778bf2aca826c710f51db4ec0687c21f1c98e1070f3a9ad7e1a809e741a5b94e20a44c56c60a8b1e4a049788ff5f2a4d581c4eedf3dbbc0da86d WHIRLPOOL dcdd705e9a69612d4672b38a00080063fca7a80123f7152fee8490018c080e0dbdbf7a74acf316f194d182acda2e6f092d1edcab56f4bc073df1f99e9b4832b0
diff --git a/games-fps/ut2003/metadata.xml b/games-fps/ut2003/metadata.xml
new file mode 100644
index 000000000000..9da2490bda56
--- /dev/null
+++ b/games-fps/ut2003/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Unreal Tounament 2003 is a first-person 3-D shooter and sequel to the 1999 Game of the Year, Unreal Tournament. The game was ported to Linux by Ryan "icculus" Gordon under contract from Epic Games and the Linux installer was released in the retail box. This game is commercial software and requires data from the original retail discs to play. If you're interested in checking out the technology behind Unreal Tournament 2003, you can "emerge ut2003-demo" to get the playable demo.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/ut2003/ut2003-2225-r4.ebuild b/games-fps/ut2003/ut2003-2225-r4.ebuild
new file mode 100644
index 000000000000..18ef1921f859
--- /dev/null
+++ b/games-fps/ut2003/ut2003-2225-r4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Sequel to the 1999 Game of the Year multi-player first-person shooter"
+HOMEPAGE="http://www.unrealtournament2003.com/"
+SRC_URI="ftp://ftp.infogrames.net/misc/ut2003/ut2003lnx_patch2225.tar.tar"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dedicated"
+RESTRICT="strip"
+
+RDEPEND="
+ games-fps/ut2003-data
+ dedicated? ( games-server/ut2003-ded )
+ !dedicated? ( virtual/opengl[abi_x86_32(-)] )
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+dir="${GAMES_PREFIX_OPT}/${PN}"
+Ddir="${D}/${dir}"
+
+src_unpack() {
+ unpack ut2003lnx_patch${PV}.tar.tar
+}
+
+src_install() {
+ insinto "${dir}"
+
+ games_make_wrapper ut2003 ./ut2003 "${dir}" "${dir}"
+ make_desktop_entry ut2003 "Unreal Tournament 2003" ut2003
+
+ # TODO: change this to use doexe/doins
+ # this brings our install up to the newest version
+ cp -r "${S}"/ut2003-lnx-2225/* "${Ddir}" || die
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ # here is where we check for the existence of a cdkey...
+ # if we don't find one, we ask the user for it
+ if [[ -f "${dir}"/System/cdkey ]] ; then
+ elog "A cdkey file is already present in ${dir}/System"
+ else
+ ewarn "You MUST run this before playing the game:"
+ ewarn "emerge --config =${CATEGORY}/${PF}"
+ ewarn "That way you can (re)enter your cdkey."
+ fi
+ elog
+ elog "To play the game run:"
+ elog " ut2003"
+ ewarn
+ ewarn "If you are not installing for the first time and you plan on running"
+ ewarn "a server, you will probably need to edit your"
+ ewarn "~/.ut2003/System/UT2003.ini file and add a line that says"
+ ewarn "AccessControlClass=crashfix.iaccesscontrolini to your"
+ ewarn "[Engine.GameInfo] section to close a security issue."
+}
+
+pkg_postrm() {
+ ewarn "This package leaves a cdkey file in ${dir}/System that you need"
+ ewarn "to remove to completely get rid of this game's files."
+}
+
+pkg_config() {
+ ewarn "Your CD key is NOT checked for validity here."
+ ewarn " Make sure you type it in correctly."
+ eerror "If you CTRL+C out of this, the game will not run!"
+ echo
+ einfo "CD key format is: XXXX-XXXX-XXXX-XXXX"
+ while true ; do
+ einfo "Please enter your CD key:"
+ read CDKEY1
+ einfo "Please re-enter your CD key:"
+ read CDKEY2
+ if [[ "${CDKEY1}" == "" ]] ; then
+ echo "You entered a blank CD key. Try again."
+ else
+ if [[ "${CDKEY1}" == "${CDKEY2}" ]] ; then
+ echo "${CDKEY1}" | tr a-z A-Z > ${dir}/System/cdkey
+ einfo "Thank you!"
+ chown games:games "${dir}"/System/cdkey
+ break
+ else
+ eerror "Your CD key entries do not match. Try again."
+ fi
+ fi
+ done
+}