summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild')
-rw-r--r--games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
new file mode 100644
index 000000000000..16ebc3d31501
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+MOD_DESC="Editor's Choice Edition bonus pack"
+MOD_NAME="Editor's Choice Edition"
+
+inherit games games-mods
+
+MY_P="ut2004megapack-linux.tar.bz2"
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="mirror://3dgamers/unrealtourn2k4/Missions/${MY_P}
+ http://0day.icculus.org/ut2004/${MY_P}
+ ftp://ftp.games.skynet.be/pub/misc/${MY_P}
+ http://sonic-lux.net/data/mirror/ut2004/${MY_P}"
+
+LICENSE="ut2003"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ mv -f UT2004MegaPack/* . || die
+ rmdir UT2004MegaPack
+
+ rm -r Music Speech
+
+ # Remove megapack files which are not in ece
+ rm Animations/ONSNewTank-A.ukx
+ rm Help/ReadMePatch.int.txt
+ # Help/{DebuggerLogo.bmp,InstallerLogo.bmp,Unreal.ico,UnrealEd.ico}
+ # are not in megapack.
+ # Keep new Help/UT2004Logo.bmp
+ # Manual dir does not exist in megapack
+ rm Maps/{AS*,CTF*,DM*}
+ rm Sounds/A_Announcer_BP2.uax
+ rm StaticMeshes/{JumpShipObjects.usx,Ty_RocketSMeshes.usx}
+ rm System/{A*,b*,B*,CacheRecords.ucl}
+ rm System/{*.det,*.est,*.frt,*.itt,*.kot}
+ rm System/{CTF*,D*,Editor*,G*,I*,L*,ONS-Arc*,Onslaught.*,*.md5}
+ rm System/{u*,U*,V*,X*,Core.u,Engine.u,F*,*.ucl,Sk*}
+ rm Textures/{J*,j*,T*}
+ rm -r Web
+
+ # The file lists of ut2004-3369-r1 and -r2 are identical
+ # Remove files owned by ut2004-3369-r2
+ rm Help/UT2004Logo.bmp
+ # The 2 Manifest files have not changed
+ rm System/{Manifest.in{i,t},OnslaughtFull.int}
+ rm System/{Core.int,Engine.int,Setup.int,Window.int}
+ rm System/{OnslaughtFull.u,OnslaughtBP.u}
+}