summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/ut2004-unwheel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/ut2004-unwheel')
-rw-r--r--games-fps/ut2004-unwheel/Manifest2
-rw-r--r--games-fps/ut2004-unwheel/metadata.xml5
-rw-r--r--games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild33
3 files changed, 40 insertions, 0 deletions
diff --git a/games-fps/ut2004-unwheel/Manifest b/games-fps/ut2004-unwheel/Manifest
new file mode 100644
index 000000000000..08847078fd3e
--- /dev/null
+++ b/games-fps/ut2004-unwheel/Manifest
@@ -0,0 +1,2 @@
+DIST UnWheel-R5_BonusPack-Volume_1.zip 138178365 SHA256 dadc3538071b9853b11202ac1cdb7769bbbacde4ae03f78919b469dab997f2b5
+DIST unwheel_r5.zip 596390232 SHA256 30473f57f9da9b1f1da27f44c181f2e284bb22141163847100ce3ac446fa264d
diff --git a/games-fps/ut2004-unwheel/metadata.xml b/games-fps/ut2004-unwheel/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/ut2004-unwheel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild b/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild
new file mode 100644
index 000000000000..8100195836db
--- /dev/null
+++ b/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+MOD_DESC="multiplayer driving mod focusing on fun driving"
+MOD_NAME="UnWheel"
+MOD_DIR="unwheel"
+
+inherit games games-mods
+
+HOMEPAGE="http://unwheel.beyondunreal.com/"
+SRC_URI="unwheel_r5.zip
+ UnWheel-R5_BonusPack-Volume_1.zip"
+
+LICENSE="GameFront"
+KEYWORDS="amd64 x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch bindist"
+
+pkg_nofetch() {
+ elog "Please download the following files:"
+ elog "http://www.filefront.com/5110896"
+ elog "http://www.filefront.com/13792114"
+ elog "and move them to ${DISTDIR}"
+}
+
+src_unpack() {
+ mkdir ${MOD_DIR}
+ cd ${MOD_DIR}
+ unpack ${A}
+}