summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/worldofpadman/worldofpadman-1.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/worldofpadman/worldofpadman-1.6.ebuild')
-rw-r--r--games-fps/worldofpadman/worldofpadman-1.6.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/games-fps/worldofpadman/worldofpadman-1.6.ebuild b/games-fps/worldofpadman/worldofpadman-1.6.ebuild
new file mode 100644
index 000000000000..d1fdd6125537
--- /dev/null
+++ b/games-fps/worldofpadman/worldofpadman-1.6.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A cartoon style multiplayer first-person shooter"
+HOMEPAGE="http://worldofpadman.com/"
+SRC_URI="mirror://sourceforge/${PN}/wop-1.5-unified.zip
+ mirror://sourceforge/${PN}/wop-1.5.x-to-1.6-patch-unified.zip"
+
+LICENSE="GPL-2 worldofpadman"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+curl dedicated maps +openal +theora +vorbis"
+
+RDEPEND="sys-libs/zlib
+ !dedicated? (
+ media-libs/speex
+ virtual/jpeg:0
+ media-libs/libsdl[opengl,video,X]
+ virtual/opengl
+ virtual/glu
+ openal? ( media-libs/openal )
+ curl? ( net-misc/curl )
+ vorbis? ( media-libs/libvorbis )
+ theora? (
+ media-libs/libtheora
+ media-libs/libogg
+ )
+ )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}_svn2178-src
+
+src_unpack() {
+ unpack ${A}
+ unzip XTRAS/"editing files"/${P}-src.zip
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e 's:JPEG_LIB_VERSION < 80:JPEG_LIB_VERSION < 62:' \
+ code/renderer/tr_image_jpg.c || die #479652
+}
+
+src_compile() {
+ local arch
+
+ if use amd64 ; then
+ arch=x86_64
+ elif use x86 ; then
+ arch=i386
+ fi
+
+ emake \
+ V=1 \
+ ARCH=${arch} \
+ BUILD_CLIENT=$(use dedicated && echo 0) \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}"/${PN} \
+ OPTIMIZE= \
+ USE_CURL=$(usex curl 1 0) \
+ USE_CURL_DLOPEN=0 \
+ USE_OPENAL=$(usex openal 1 0) \
+ USE_OPENAL_DLOPEN=0 \
+ USE_CODEC_VORBIS=$(usex vorbis 1 0) \
+ USE_CIN_THEORA=$(usex theora 1 0) \
+ USE_RENDERER_DLOPEN=0 \
+ USE_INTERNAL_ZLIB=0 \
+ USE_INTERNAL_JPEG=0 \
+ USE_INTERNAL_SPEEX=0
+}
+
+src_install() {
+ newgamesbin build/release-*/wopded.* ${PN}-ded
+ if ! use dedicated ; then
+ newgamesbin build/release-*/wop.* ${PN}
+ newicon misc/quake3.png ${PN}.png
+ make_desktop_entry ${PN} "World of Padman"
+ fi
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../wop
+
+ dodoc id-readme.txt \
+ IOQ3-README \
+ voip-readme.txt \
+ ../XTRAS/changelog.txt \
+ ../XTRAS/sounds_readme.txt
+ dohtml -r ../XTRAS/readme{,.html}
+ prepgamesdirs
+}