summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-02-22 17:44:53 +0900
committerJames Le Cuirot <chewi@gentoo.org>2021-02-24 20:47:27 +0000
commit1af745b8ccc6841ef212231ff721b354dea991cb (patch)
tree92e132b8d9e22760f87dc3b6e52e90de576dd65b /games-fps
parentprofiles: Mask www-client/vivaldi-snapshot-3.7.2202.3 (diff)
downloadgentoo-1af745b8ccc6841ef212231ff721b354dea991cb.tar.gz
gentoo-1af745b8ccc6841ef212231ff721b354dea991cb.tar.bz2
gentoo-1af745b8ccc6841ef212231ff721b354dea991cb.zip
games-fps/prboom-plus: Bump to version 2.6
Closes: https://bugs.gentoo.org/769737 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19592 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/prboom-plus/Manifest1
-rw-r--r--games-fps/prboom-plus/files/prboom-plus-2.6-Set-CMAKE_INSTALL_DOCDIR-as-a-cache-entry.patch29
-rw-r--r--games-fps/prboom-plus/prboom-plus-2.6.ebuild63
3 files changed, 93 insertions, 0 deletions
diff --git a/games-fps/prboom-plus/Manifest b/games-fps/prboom-plus/Manifest
index 9acad2caf4b3..6be7818da6d3 100644
--- a/games-fps/prboom-plus/Manifest
+++ b/games-fps/prboom-plus/Manifest
@@ -1 +1,2 @@
DIST prboom-plus-2.5.1.7.82.tar.gz 1541604 BLAKE2B 7c10754aa5f85879b63a3778d87e8e2fcd21fcd5092f96a31dc087e878ca080b9ce48d2e7d8f5cac9aa05c8a69cf5f6e9661a5b581de7afe21d59a18af2e57e9 SHA512 55f0ec4edcbac80174aadc63f1f77f3b868a6d1e8efc309ed6f71898d486a3c31d18e08130c9b4a6afd63185003bfd11e6b5940b550071f60168b3c716845f0f
+DIST prboom-plus-2.6.tar.gz 1526732 BLAKE2B 00c0eeb0dfb5a99a427c986e557b6616e69be3b98373582c3aa54585136e3a16b67c0176faec59ebc011112bc8764da78b34215ae4c00b490f12820b26704e45 SHA512 c2f8c6895683ee22d729ad2c9dc10bd821e5bdb55d75b88b4c6db25b8f3604370d18285677660c82761912a159b0c1068a6fcf1c8333e20d849fa1087a74800f
diff --git a/games-fps/prboom-plus/files/prboom-plus-2.6-Set-CMAKE_INSTALL_DOCDIR-as-a-cache-entry.patch b/games-fps/prboom-plus/files/prboom-plus-2.6-Set-CMAKE_INSTALL_DOCDIR-as-a-cache-entry.patch
new file mode 100644
index 000000000000..8f07606acd3c
--- /dev/null
+++ b/games-fps/prboom-plus/files/prboom-plus-2.6-Set-CMAKE_INSTALL_DOCDIR-as-a-cache-entry.patch
@@ -0,0 +1,29 @@
+From 9f56505b7c41337cab3a6ce3f882cf8df6bf29a9 Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Mon, 22 Feb 2021 18:27:24 +0900
+Subject: [PATCH] Set CMAKE_INSTALL_DOCDIR as a cache entry
+
+CMAKE_INSTALL_DOCDIR is being unconditionally set which prevents users
+from supplying their own docdir preference. This changes the behavior to
+set CMAKE_INSTALL_DOCDIR as a cache entry so that users can override the
+default install location if they so wish.
+---
+ prboom2/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/prboom2/CMakeLists.txt b/prboom2/CMakeLists.txt
+index 9c2c1fde..3110d7f3 100644
+--- a/prboom2/CMakeLists.txt
++++ b/prboom2/CMakeLists.txt
+@@ -38,7 +38,7 @@ set(PACKAGE_TARNAME "prboom-plus")
+ set(PACKAGE_VERSION "${PROJECT_VERSION}um")
+ set(PACKAGE_HOMEPAGE "${PROJECT_HOMEPAGE_URL}")
+ set(PACKAGE_STRING "${PROJECT_NAME} ${PROJECT_VERSION}")
+-set(CMAKE_INSTALL_DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${PACKAGE_TARNAME}")
++set(CMAKE_INSTALL_DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${PACKAGE_TARNAME}" CACHE PATH "")
+
+ include(CheckSymbolExists)
+
+--
+2.30.1
+
diff --git a/games-fps/prboom-plus/prboom-plus-2.6.ebuild b/games-fps/prboom-plus/prboom-plus-2.6.ebuild
new file mode 100644
index 000000000000..dcd77904bd3f
--- /dev/null
+++ b/games-fps/prboom-plus/prboom-plus-2.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg
+
+DESCRIPTION="An enhanced clone of the classic first-person shooter Doom"
+HOMEPAGE="https://github.com/coelckers/prboom-plus/"
+SRC_URI="http://deb.debian.org/debian/pool/main/p/prboom-plus/${PN}_${PV}um.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-3+ BSD BSD-2 BSD-with-disclosure CC-BY-3.0 CC0-1.0 LGPL-2.1+ MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dumb fluidsynth mad net +opengl +pcre portmidi sdl2-image +sdl2-mixer server vorbis zlib"
+REQUIRED_USE="server? ( net )"
+
+DEPEND="
+ media-libs/libsdl2[opengl?,joystick,sound,video]
+ dumb? ( media-libs/dumb:= )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ mad? ( media-libs/libmad )
+ net? ( media-libs/sdl2-net )
+ pcre? ( dev-libs/libpcre:3 )
+ portmidi? ( media-libs/portmidi )
+ sdl2-image? ( media-libs/sdl2-image )
+ sdl2-mixer? ( media-libs/sdl2-mixer[midi] )
+ vorbis? ( media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}um/prboom2"
+
+src_prepare() {
+ eapply -p2 "${FILESDIR}/${P}-Set-CMAKE_INSTALL_DOCDIR-as-a-cache-entry.patch"
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_GL="$(usex opengl)"
+ -DWITH_IMAGE="$(usex sdl2-image)"
+ -DWITH_MIXER="$(usex sdl2-mixer)"
+ -DWITH_NET="$(usex net)"
+ -DWITH_PCRE="$(usex pcre)"
+ -DWITH_ZLIB="$(usex zlib)"
+ -DWITH_MAD="$(usex mad)"
+ -DWITH_FLUIDSYNTH="$(usex fluidsynth)"
+ -DWITH_DUMB="$(usex dumb)"
+ -DWITH_VORBISFILE="$(usex vorbis)"
+ -DWITH_PORTMIDI="$(usex portmidi)"
+ -DDOOMWADDIR="${EPREFIX}/usr/share/doom"
+ -DWAD_DATA_PATH="${EPREFIX}/usr/share/doom"
+ -DBUILD_SERVER="$(usex server)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ doicon -s scalable ICONS/${PN}.svg
+ domenu ICONS/${PN}.desktop
+ cmake_src_install
+}