summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-09 19:24:24 +0000
committerSam James <sam@gentoo.org>2021-04-09 19:31:31 +0000
commit27c7624d158e5b26e53564911c696165bc749b96 (patch)
tree27a3c5c5bdef4a42458f5608d41ae6f1aa9e2732 /games-fps
parentgames-fps/ut2003-data: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-27c7624d158e5b26e53564911c696165bc749b96.tar.gz
gentoo-27c7624d158e5b26e53564911c696165bc749b96.tar.bz2
gentoo-27c7624d158e5b26e53564911c696165bc749b96.zip
games-fps/ut2003-bonuspack-epic: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1-r1.ebuild (renamed from games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild)26
1 files changed, 12 insertions, 14 deletions
diff --git a/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild b/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1-r1.ebuild
index 00d2d8927eef..70fff75aec7d 100644
--- a/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
+++ b/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1-r1.ebuild
@@ -1,29 +1,30 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit games
+EAPI=7
DESCRIPTION="Epic Bonus Pack for UT2003"
HOMEPAGE="https://www.moddb.com/games/unreal-tournament-2003"
SRC_URI="http://ftp.student.utwente.nl/pub/games/UT2003/BonusPack/UT2003-epicbonuspackone.exe"
+S="${WORKDIR}"/UT2003-BonusPack
LICENSE="ut2003"
SLOT="1"
KEYWORDS="~x86"
-IUSE=""
RESTRICT="strip"
-DEPEND="app-arch/unzip"
-RDEPEND="games-fps/ut2003"
+RDEPEND="
+ acct-group/gamestat
+ games-fps/ut2003
+"
+BDEPEND="app-arch/unzip"
-S=${WORKDIR}/UT2003-BonusPack
-
-dir=${GAMES_PREFIX_OPT}/ut2003
-Ddir=${D}/${dir}
+dir=opt/ut2003
+Ddir="${ED}"/${dir}
src_unpack() {
unzip -qq "${DISTDIR}"/${A} || die
+
# This is done since the files are the same
rm -f "${S}"/Textures/LastManStanding.utx || die
}
@@ -39,12 +40,9 @@ src_install() {
cp -r "${S}"/{Maps,Sounds,StaticMeshes,Textures} "${Ddir}" || die
cp "${S}"/System/{*.{det,est,frt,int,itt,kot,tmt,u},User.ini} "${Ddir}"/System || die
cp -v "${S}"/System/Manifest.ini "${Ddir}"/System/Manifest.ini.epic || die
-
- prepgamesdirs
}
pkg_postinst() {
- games_pkg_postinst
elog "You will need to run:"
elog "emerge --config =${CATEGORY}/${PF}"
elog "to make the necessary changes to the system .ini files."
@@ -106,5 +104,5 @@ EOT
cp DefUser.ini DefUser.ini.pre-epic || die
sed -i 's/^F11=.*$/F11=MusicMenu/g' DefUser.ini || die
- chown games:games ${dir}/System/*.ini || die
+ chown :gamestat "${dir}"/System/*.ini || die
}