summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 02:09:01 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:17:50 +0100
commit34b62e6594e4c384657095bb7a0ceca69d8a707b (patch)
tree4298e15d5555f6160060f9388df23255a282ad7a /games-fps
parentgames-misc/little-inferno: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-34b62e6594e4c384657095bb7a0ceca69d8a707b.tar.gz
gentoo-34b62e6594e4c384657095bb7a0ceca69d8a707b.tar.bz2
gentoo-34b62e6594e4c384657095bb7a0ceca69d8a707b.zip
games-fps/glxquake-bin: port to EAPI 7, games.eclass--, improve pkg_postinst
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/glxquake-bin/glxquake-bin-0-r3.ebuild (renamed from games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild)28
1 files changed, 13 insertions, 15 deletions
diff --git a/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild b/games-fps/glxquake-bin/glxquake-bin-0-r3.ebuild
index 14f81de25338..eb9cce08a4ba 100644
--- a/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild
+++ b/games-fps/glxquake-bin/glxquake-bin-0-r3.ebuild
@@ -1,42 +1,40 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit games
+EAPI=7
DESCRIPTION="A binary that works with any 3D-graphics-card that supports the glx X-extension"
HOMEPAGE="http://mfcn.ilo.de/glxquake/"
SRC_URI="http://www.wh-hms.uni-ulm.de/~mfcn/shared/glxquake/glxquake.tar.gz"
+S="${WORKDIR}"/glxquake
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
RESTRICT="strip"
-IUSE=""
-RDEPEND="sys-libs/glibc
+RDEPEND="
+ sys-libs/glibc
amd64? ( sys-libs/glibc[multilib] )
virtual/opengl[abi_x86_32(-)]
x11-libs/libX11[abi_x86_32(-)]
x11-libs/libXext[abi_x86_32(-)]
x11-libs/libXxf86vm[abi_x86_32(-)]
- x11-libs/libXxf86dga[abi_x86_32(-)]"
+ x11-libs/libXxf86dga[abi_x86_32(-)]
+"
-S=${WORKDIR}/glxquake
-
-QA_PREBUILT="${GAMES_BINDIR:1}/glquake"
+QA_PREBUILT="usr/bin/glquake"
src_install() {
- dogamesbin glquake
+ dobin glquake
dodoc README
- prepgamesdirs
}
pkg_postinst() {
- games_pkg_postinst
- elog "To play with it, create a subdirectory called id1"
+ elog "To play with ${PN}, create a subdirectory called id1"
elog "Copy the pak0.pak, and eventually pak1.pak into this subdirectory"
- elog "You can eventually get pak0.pak emerging games-fps/quake1-demodata"
- elog "The file pak0.pak will be on the ${GAMES_DATADIR}/quake1/demo/"
+ elog "You can get pak0.pa by emerging games-fps/quake1-demodata"
+ elog "(or use the disc)"
+ elog "The file pak0.pak will be in /usr/share/quake1/demo/"
elog "You can now run glxquake by executing glquake"
}