summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-11-28 23:03:44 +1100
committerSam James <sam@gentoo.org>2023-01-28 03:18:17 +0000
commit360b455bade6394f7296048062f0ddd77674b6c5 (patch)
treeef553b5c8bc56be3957394c389151c4c10dd6e30 /games-fps
parentgames-fps/alephone: drop 20220115-r1 (diff)
downloadgentoo-360b455bade6394f7296048062f0ddd77674b6c5.tar.gz
gentoo-360b455bade6394f7296048062f0ddd77674b6c5.tar.bz2
gentoo-360b455bade6394f7296048062f0ddd77674b6c5.zip
games-fps/alephone-marathon: add 20221126
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone-marathon/Manifest1
-rw-r--r--games-fps/alephone-marathon/alephone-marathon-20221126.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-fps/alephone-marathon/Manifest b/games-fps/alephone-marathon/Manifest
index 4395a19b6a3f..80a802dba9d1 100644
--- a/games-fps/alephone-marathon/Manifest
+++ b/games-fps/alephone-marathon/Manifest
@@ -1 +1,2 @@
DIST Marathon-20220115-Data.zip 26473230 BLAKE2B d6a917c0e884d128af11a56473cd4ec0022ca373c4c1e33f39b58ed24cd65a3cb40efd3e874f9ef64be6d3bf39206cd3a51310719223788d240747670075f697 SHA512 dd1eaaafcffe03b66244497c69044a3cabb8348186f1023dd08444a519a6fca59330bc5daf4950967482a12167059055d577e8211f3a70c92f512f74c8415bc8
+DIST Marathon-20221126-Data.zip 26473388 BLAKE2B 16e93da81942c77ff399364d16a9b554c9f13320f08604006dc991b0be24db69d2a6496c45053d2ebb66628f3f2024d09953cec565d6fbdf8d6380f593f47e3e SHA512 4fcf16fcf0a04ccb5ce1fc4dc0ef95a09ff9010f444438c830977490401d3ca01e10d1ffe429df804d3ed6683e8b8f5aed982ca5a3e3049a23b074c783fb7c61
diff --git a/games-fps/alephone-marathon/alephone-marathon-20221126.ebuild b/games-fps/alephone-marathon/alephone-marathon-20221126.ebuild
new file mode 100644
index 000000000000..020967a4d7da
--- /dev/null
+++ b/games-fps/alephone-marathon/alephone-marathon-20221126.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon (M1A1)"
+HOMEPAGE="https://alephone.lhowon.org/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/Marathon-${PV}-Data.zip"
+S="${WORKDIR}/Marathon"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="marathon"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}