summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-11-28 23:05:40 +1100
committerSam James <sam@gentoo.org>2023-01-28 03:18:18 +0000
commit53a6e3fd8af9a3575f6d5e75f3dd9fc185e7739c (patch)
treed610df5c5f0d36a0c4c145ac8faa6a81b2edb194 /games-fps
parentgames-fps/alephone-marathon: drop 20220115 (diff)
downloadgentoo-53a6e3fd8af9a3575f6d5e75f3dd9fc185e7739c.tar.gz
gentoo-53a6e3fd8af9a3575f6d5e75f3dd9fc185e7739c.tar.bz2
gentoo-53a6e3fd8af9a3575f6d5e75f3dd9fc185e7739c.zip
games-fps/alephone-durandal: add 20221126
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone-durandal/Manifest1
-rw-r--r--games-fps/alephone-durandal/alephone-durandal-20221126.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-fps/alephone-durandal/Manifest b/games-fps/alephone-durandal/Manifest
index 2fd3b7db5e63..d3b141ff32fa 100644
--- a/games-fps/alephone-durandal/Manifest
+++ b/games-fps/alephone-durandal/Manifest
@@ -1 +1,2 @@
DIST Marathon2-20220115-Data.zip 29710307 BLAKE2B eadf9dac7ad9bedec5b4484c74b5bc4c342223d209af0a4ce90c58649833642c8127a7c21ec87efe1d6229018d6b1002ca1a63b5ed8634103547796e1750c559 SHA512 3f259a865bd9d3709fdc79722e5b0cffd3ddfec981310a00898d2a1348c6b2ffcee0fe36a8ef2da26f235e800703e24ab8f33fbfb3ed8f96a6fc46f84808700f
+DIST Marathon2-20221126-Data.zip 29711060 BLAKE2B aa65a575a2b36a9b07cfc978042aa31485e2e02de7886fc7505ca430e7c8e67d1b2b9a77578777abe1042192f82bd7a40f2ab5e848d6a5d4a2e48ddd0b8f075d SHA512 18911eb415b66d6a698c56a6343eb319d9fd2baa34b408d26e0800f2028e0a5724556530beda8660b5f6b071e1544ad7ee59307888e6d021c7628c295e813147
diff --git a/games-fps/alephone-durandal/alephone-durandal-20221126.ebuild b/games-fps/alephone-durandal/alephone-durandal-20221126.ebuild
new file mode 100644
index 000000000000..ae8fcfa41812
--- /dev/null
+++ b/games-fps/alephone-durandal/alephone-durandal-20221126.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon 2 (Durandal)"
+HOMEPAGE="https://alephone.lhowon.org/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/Marathon2-${PV}-Data.zip"
+S="${WORKDIR}/Marathon 2"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="durandal"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}