summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-25 21:34:55 +0000
committerSam James <sam@gentoo.org>2021-04-25 22:00:49 +0000
commit6958d869845a99bc183b642ea88d4ba53fbaa4bb (patch)
tree0251e3e446f171a1d8064e9cc46dc3f46e790e22 /games-fps
parentapp-forensics/aflplusplus: respect CXX (diff)
downloadgentoo-6958d869845a99bc183b642ea88d4ba53fbaa4bb.tar.gz
gentoo-6958d869845a99bc183b642ea88d4ba53fbaa4bb.tar.bz2
gentoo-6958d869845a99bc183b642ea88d4ba53fbaa4bb.zip
games-fps/nexuiz: avoid stripping files
Closes: https://bugs.gentoo.org/739294 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild b/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
index 68bb3ae1edc8..f9054d23eec3 100644
--- a/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
+++ b/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit desktop toolchain-funcs
MY_PN=Nexuiz
@@ -87,7 +88,13 @@ src_prepare() {
}
src_compile() {
+ # Unset STRIP because the build system by default will not strip
+ # If users express a preference, this triggers strip
+ # bug #739294
+ unset STRIP
+
tc-export CC
+
if use opengl || ! use dedicated ; then
emake cl-${PN}
if use sdl ; then