summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 07:36:20 +0000
committerSam James <sam@gentoo.org>2021-04-04 07:37:42 +0000
commit737cdff9da9fc68da2082bd5fb9185744151b90a (patch)
tree465f755690f51a171807c50ca48551f649957717 /games-fps
parentgames-action/crimsonland: eutils->wrapper (diff)
downloadgentoo-737cdff9da9fc68da2082bd5fb9185744151b90a.tar.gz
gentoo-737cdff9da9fc68da2082bd5fb9185744151b90a.tar.bz2
gentoo-737cdff9da9fc68da2082bd5fb9185744151b90a.zip
games-fps/blackshades: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/blackshades/blackshades-20070723-r1.ebuild27
1 files changed, 21 insertions, 6 deletions
diff --git a/games-fps/blackshades/blackshades-20070723-r1.ebuild b/games-fps/blackshades/blackshades-20070723-r1.ebuild
index a531ebbe5987..1ae58711d3a8 100644
--- a/games-fps/blackshades/blackshades-20070723-r1.ebuild
+++ b/games-fps/blackshades/blackshades-20070723-r1.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit desktop toolchain-funcs
DESCRIPTION="You control a psychic bodyguard, and try to protect the VIP"
HOMEPAGE="http://www.wolfire.com/blackshades.html
http://www.icculus.org/blackshades/"
SRC_URI="http://filesingularity.timedoctor.org/Textures.tar.bz2
mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}"/${PN}
LICENSE="blackshades"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="
media-libs/freealut
@@ -24,8 +25,6 @@ DEPEND="
virtual/opengl"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}
-
PATCHES=(
"${FILESDIR}"/${PN}-datadir.patch
)
@@ -36,25 +35,41 @@ src_prepare() {
rm -rf Data/Textures || die
rm -f ../Textures/{,Blood/}._* || die
mv -f ../Textures Data || die "mv failed"
+
sed -i \
-e "s/-O2 \(-Wall\) -g/${CXXFLAGS} \1/" \
-e "/^LINKER/s:$: ${LDFLAGS}:" \
Makefile \
|| die "sed Makefile failed"
+
+ sed -i \
+ -e "s/CC := gcc/CC ?= gcc/" \
+ -e "s/CXX := g++/CXX ?= g++/" \
+ -e "s/LINKER := g++/LINKER ?= g++/" \
+ -e "s/LDFLAGS := /LDFLAGS := ${LDFLAGS} /" \
+ Makefile || die
+
sed -i "s:@DATADIR@:/usr/share/${PN}:" \
Source/Main.cpp \
|| die "sed Main.cpp failed"
}
src_compile() {
+ tc-export CC CXX
+
+ export LINKER="${CXX}"
+
emake bindir
emake
}
src_install() {
newbin objs/blackshades ${PN}
+
insinto /usr/share/${PN}
doins -r Data
+
dodoc IF_THIS_IS_A_README_YOU_HAVE_WON Readme TODO uDevGame_Readme
+
make_desktop_entry ${PN} "Black Shades"
}