summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 02:27:14 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:17:56 +0100
commit820bf3053f18fd62a60284ef54ca900cc688844a (patch)
tree6fa877e5c30cc5d35b0a49018abfdbcebac18614 /games-fps
parentgames-emulation/zsnes: use BDEPEND, drop ${GAMES_BINDIR} ref (diff)
downloadgentoo-820bf3053f18fd62a60284ef54ca900cc688844a.tar.gz
gentoo-820bf3053f18fd62a60284ef54ca900cc688844a.tar.bz2
gentoo-820bf3053f18fd62a60284ef54ca900cc688844a.zip
games-fps/ezquake-bin: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ezquake-bin/ezquake-bin-2.2-r1.ebuild (renamed from games-fps/ezquake-bin/ezquake-bin-2.2.ebuild)52
1 files changed, 26 insertions, 26 deletions
diff --git a/games-fps/ezquake-bin/ezquake-bin-2.2.ebuild b/games-fps/ezquake-bin/ezquake-bin-2.2-r1.ebuild
index 5e6fe5800999..f84c116cd555 100644
--- a/games-fps/ezquake-bin/ezquake-bin-2.2.ebuild
+++ b/games-fps/ezquake-bin/ezquake-bin-2.2-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit games
+EAPI=7
+
+inherit wrapper
MY_FULL_PV=1.9.3
MY_PN="${PN/-bin/}"
@@ -12,57 +13,56 @@ SRC_URI="
amd64? ( mirror://sourceforge/${MY_PN}/${MY_PN}_linux-x86_64.${MY_FULL_PV}.tar.gz
mirror://sourceforge/${MY_PN}/${MY_PN}_linux64_${PV}.tar.gz )
x86? ( mirror://sourceforge/${MY_PN}/${MY_PN}_linux-x86_${MY_FULL_PV}.tar.gz
- mirror://sourceforge/${MY_PN}/${MY_PN}_linux32_${PV}.tar.gz )"
+ mirror://sourceforge/${MY_PN}/${MY_PN}_linux32_${PV}.tar.gz )
+"
+S="${WORKDIR}"/${MY_PN}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="strip mirror"
+KEYWORDS="-* ~amd64 ~x86"
IUSE="cdinstall"
+RESTRICT="strip mirror"
+
DEPEND="cdinstall? ( games-fps/quake1-data )"
-RDEPEND="${DEPEND}
+RDEPEND="
+ ${DEPEND}
virtual/opengl
x11-libs/libXxf86dga
- x11-libs/libXxf86vm"
-
-S=${WORKDIR}/${MY_PN}
+ x11-libs/libXxf86vm
+"
-dir=${GAMES_PREFIX_OPT}/${PN}
-
-QA_PREBUILT="${dir:1}/ezquake*"
+MY_DIR=opt/${PN}
+QA_PREBUILT="${MY_DIR:1}/ezquake*"
src_unpack() {
unpack ${A}
+
if use amd64; then
- mv ${MY_PN}_linux-x86_64.${MY_FULL_PV} "${MY_PN}"
- mv ezquake-gl_linux-x64.glx "${MY_PN}"/ezquake-gl.glx
+ mv ${MY_PN}_linux-x86_64.${MY_FULL_PV} "${MY_PN}" || die
+ mv ezquake-gl_linux-x64.glx "${MY_PN}"/ezquake-gl.glx || die
else
- mv ${MY_PN}_linux-x86.${MY_FULL_PV} "${MY_PN}"
- mv ezquake-gl_linux-x86.glx "${MY_PN}"/ezquake-gl.glx
+ mv ${MY_PN}_linux-x86.${MY_FULL_PV} "${MY_PN}" || die
+ mv ezquake-gl_linux-x86.glx "${MY_PN}"/ezquake-gl.glx || die
fi
}
src_install() {
- exeinto "${dir}"
- insinto "${dir}"
+ exeinto ${MY_DIR}
+ insinto ${MY_DIR}
doexe ezquake-gl.glx
doins -r ezquake qw
- dosym "${GAMES_DATADIR}"/quake1/id1 "${dir}"/id1
- games_make_wrapper ezquake-gl.glx ./ezquake-gl.glx "${dir}" "${dir}"
-
- prepgamesdirs
+ dosym ../../usr/share/quake1/id1 ${MY_DIR}/id1
+ make_wrapper ezquake-gl.glx ./ezquake-gl.glx "${MY_DIR}" "${MY_DIR}"
}
pkg_postinst() {
- games_pkg_postinst
-
if ! use cdinstall; then
elog "NOTE that this client doesn't include .pak files. You *should*"
elog "enable \"cdinstall\" flag or install quake1-demodata with the symlink use flag."
elog "You can also copy the files from your Quake1 CD to"
- elog " ${dir}/quake1/id1 (all names lowercase)"
+ elog " ${MY_DIR}/quake1/id1 (all names lowercase)"
elog ""
elog "You may also want to check:"
elog " http://fuhquake.quakeworld.nu - complete howto on commands and variables"