summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 10:42:14 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:31:35 +0200
commitc714b45fd534c4e4c34c42ed19e8ecdd9fb5ba8b (patch)
treeb160003b8cf93675ca028c33c2c44397b28b9c6a /games-fps
parentgames-fps/openarena: Stop using games.eclass (diff)
downloadgentoo-c714b45fd534c4e4c34c42ed19e8ecdd9fb5ba8b.tar.gz
gentoo-c714b45fd534c4e4c34c42ed19e8ecdd9fb5ba8b.tar.bz2
gentoo-c714b45fd534c4e4c34c42ed19e8ecdd9fb5ba8b.zip
games-fps/openarena: Drop old
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/openarena/openarena-0.8.8.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/games-fps/openarena/openarena-0.8.8.ebuild b/games-fps/openarena/openarena-0.8.8.ebuild
deleted file mode 100644
index 63ae43948870..000000000000
--- a/games-fps/openarena/openarena-0.8.8.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils flag-o-matic versionator games
-
-DESCRIPTION="Open-source replacement for Quake 3 Arena"
-HOMEPAGE="http://openarena.ws/"
-SRC_URI="mirror://sourceforge/oarena/${P}.zip
- mirror://sourceforge/oarena/src/${PN}-engine-source-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+curl +openal +vorbis"
-
-RDEPEND="
- media-libs/libsdl[joystick,opengl,video]
- media-libs/speex
- media-libs/speexdsp
- virtual/jpeg:0
- virtual/opengl
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- curl? ( net-misc/curl )
- openal? ( media-libs/openal )
- vorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-MY_S=${WORKDIR}/${PN}-engine-source-${PV}
-BUILD_DIR=${PN}-build
-DIR=${GAMES_DATADIR}/${PN}
-
-src_prepare() {
- cd "${WORKDIR}"
- epatch "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-unbundling.patch
- cd "${MY_S}"
- touch jpegint.h
-}
-
-src_compile() {
- local myopts
-
- # enable voip, disable mumble
- # also build always server and use smp by default
- myopts="USE_INTERNAL_SPEEX=0 USE_VOIP=1 USE_MUMBLE=0
- BUILD_SERVER=1 BUILD_CLIENT_SMP=1 USE_LOCAL_HEADERS=0"
- use curl || myopts="${myopts} USE_CURL=0"
- use openal || myopts="${myopts} USE_OPENAL=0"
- use vorbis || myopts="${myopts} USE_CODEC_VORBIS=0"
-
- cd "${MY_S}"
- emake \
- V=1 \
- DEFAULT_BASEDIR="${DIR}" \
- BR="${BUILD_DIR}" \
- ${myopts} \
- OPTIMIZE=
-}
-
-src_install() {
- cd "${MY_S}"/"${BUILD_DIR}"
- newgamesbin openarena-smp.* "${PN}"
- newgamesbin oa_ded.* "${PN}-ded"
- cd "${S}"
-
- insinto "${DIR}"
- doins -r baseoa missionpack
-
- dodoc CHANGES CREDITS LINUXNOTES README
- newicon "${MY_S}"/misc/quake3.png ${PN}.png
- make_desktop_entry ${PN} "OpenArena"
-
- prepgamesdirs
-}