summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 01:26:05 +0000
committerSam James <sam@gentoo.org>2021-04-07 01:57:36 +0000
commitfb43d595458946ec20cc09c0dc89ef91ae1b346c (patch)
treede8234e5e59e93949044bf98da79ecf3da56cbb9 /games-fps
parentgames-fps/quake1-textures: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-fb43d595458946ec20cc09c0dc89ef91ae1b346c.tar.gz
gentoo-fb43d595458946ec20cc09c0dc89ef91ae1b346c.tar.bz2
gentoo-fb43d595458946ec20cc09c0dc89ef91ae1b346c.zip
games-fps/quake2-demodata: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-demodata/quake2-demodata-3.14-r1.ebuild (renamed from games-fps/quake2-demodata/quake2-demodata-3.14.ebuild)28
1 files changed, 13 insertions, 15 deletions
diff --git a/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild b/games-fps/quake2-demodata/quake2-demodata-3.14-r1.ebuild
index bcca12997738..b7fe8cd32c7d 100644
--- a/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
+++ b/games-fps/quake2-demodata/quake2-demodata-3.14-r1.ebuild
@@ -1,16 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit unpacker eutils versionator games
+EAPI=7
-MY_PV=$(delete_all_version_separators)
+inherit unpacker
+
+#MY_PV=$(delete_all_version_separators)
+MY_PV=$(ver_rs 1- '')
MY_PN="quake2"
FILE="q2-${MY_PV}-demo-x86.exe"
DESCRIPTION="Demo data for Quake 2"
HOMEPAGE="https://en.wikipedia.org/wiki/Quake_II"
SRC_URI="mirror://idsoftware/${MY_PN}/${FILE}"
+S="${WORKDIR}"
# See license.txt - it's a bit different to Q2EULA in Portage
LICENSE="quake2-demodata"
@@ -18,19 +21,17 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
IUSE="symlink"
-RDEPEND=""
-DEPEND="app-arch/unzip
- !games-fps/quake2-data" # games-fps/quake2-data already includes the demo data
+RDEPEND="!games-fps/quake2-data" # games-fps/quake2-data already includes the demo data
+BDEPEND="app-arch/unzip"
-S=${WORKDIR}
-dir=${GAMES_DATADIR}/${MY_PN}
+dir=usr/share/${MY_PN}
src_unpack() {
unpack_zip ${A}
}
src_install() {
- insinto "${dir}"/demo
+ insinto ${dir}/demo
doins -r Install/Data/baseq2/{pak0.pak,players}
dodoc Install/Data/DOCS/*.txt
@@ -38,15 +39,12 @@ src_install() {
if use symlink ; then
# Make the demo the default, so that people can just run it,
# without having to mess with command-line options.
- cd "${D}/${dir}" && ln -sfn demo baseq2
+ cd "${ED}"/${dir} || die
+ ln -sfn demo baseq2 || die
fi
-
- prepgamesdirs
}
pkg_postinst() {
- games_pkg_postinst
-
elog "This is just the demo data. To play, install a client"
elog "such as games-fps/qudos"
echo