summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-25 00:47:55 -0400
committerSam James <sam@gentoo.org>2024-03-25 09:20:48 +0000
commit1f7d2ab53952c3b003278d0eb3edb8ddc1ae45d4 (patch)
tree22fab2da784cfed7151c163a6da1ae07ce29be97 /games-kids/memonix/memonix-1.6-r1.ebuild
parentgames-fps/doomsday: mark as LTO-unsafe (diff)
downloadgentoo-1f7d2ab53952c3b003278d0eb3edb8ddc1ae45d4.tar.gz
gentoo-1f7d2ab53952c3b003278d0eb3edb8ddc1ae45d4.tar.bz2
gentoo-1f7d2ab53952c3b003278d0eb3edb8ddc1ae45d4.zip
games-kids/memonix: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/858782 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-kids/memonix/memonix-1.6-r1.ebuild')
-rw-r--r--games-kids/memonix/memonix-1.6-r1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/games-kids/memonix/memonix-1.6-r1.ebuild b/games-kids/memonix/memonix-1.6-r1.ebuild
index f21368cfc488..9cb2034ef1ba 100644
--- a/games-kids/memonix/memonix-1.6-r1.ebuild
+++ b/games-kids/memonix/memonix-1.6-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake desktop wrapper
+inherit cmake desktop flag-o-matic wrapper
DESCRIPTION="Brain teasers, puzzle and memory games for kid's in one pack"
HOMEPAGE="https://www.viewizard.com/memonix/"
@@ -21,6 +21,17 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858782
+ #
+ # Upstream site has been taken down for a long time.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ cmake_src_configure
+}
+
src_install() {
exeinto /usr/"$(get_libdir)"
doexe ../${P}_build/Memonix