summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1.ebuild')
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1.ebuild
new file mode 100644
index 000000000000..2ec298f017cb
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 multilib games
+
+MY_PN=TuxMathScrabble
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="https://github.com/asymptopia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}
+ dev-python/wxpython[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ app-arch/unzip"
+RDEPEND="${CDEPEND}
+ dev-python/pygame[${PYTHON_USEDEP}]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ rm -f $(find . -name '*.pyc')
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${MY_PN}:" \
+ ${MY_PN}/tms.py \
+ .tms_config_master \
+ || die "sed failed"
+ sed -i \
+ -e "s:python2.7-32:python:g" \
+ ${PN}.py || die "2nd sed failed"
+ python_fix_shebang .
+}
+
+src_install() {
+ newgamesbin ${PN}.py ${PN}
+
+ insinto $(python_get_sitedir)
+ doins -r ${MY_PN}
+
+ insinto "${GAMES_DATADIR}"/${MY_PN}
+ doins -r .tms_config_master Font
+
+ python_optimize
+
+ newicon tms.ico ${PN}.ico
+ make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico
+
+ dodoc CHANGES README
+ prepgamesdirs
+}