summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-03-28 00:15:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-03-28 00:20:30 -0400
commit19102942b5d6049be39126e08436fd9e49dbc8e1 (patch)
tree2ec0d33354ce4f194c55736db24ef5b534de2bb1 /games-kids
parentprofiles: mask dev-python/reportlab-3.6.9 (hangs in compile) (diff)
downloadgentoo-19102942b5d6049be39126e08436fd9e49dbc8e1.tar.gz
gentoo-19102942b5d6049be39126e08436fd9e49dbc8e1.tar.bz2
gentoo-19102942b5d6049be39126e08436fd9e49dbc8e1.zip
games-kids/gmult: fix build with meson-0.61.4
meson-0.61.4's gnome module now checks that gtk4-update-icon-cache is available if updating cache is requested (was ignored with <=0.61.3), simply skip given this should be handled by xdg.eclass either way. Closes: https://bugs.gentoo.org/836294 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gmult/files/gmult-10.0-no-icon-cache.patch8
-rw-r--r--games-kids/gmult/gmult-10.0.ebuild4
2 files changed, 12 insertions, 0 deletions
diff --git a/games-kids/gmult/files/gmult-10.0-no-icon-cache.patch b/games-kids/gmult/files/gmult-10.0-no-icon-cache.patch
new file mode 100644
index 000000000000..2a355c17e228
--- /dev/null
+++ b/games-kids/gmult/files/gmult-10.0-no-icon-cache.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/836294
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -56,3 +56,3 @@
+ gnome.post_install(
+- gtk_update_icon_cache: true,
++ gtk_update_icon_cache: false,
+ )
diff --git a/games-kids/gmult/gmult-10.0.ebuild b/games-kids/gmult/gmult-10.0.ebuild
index 6df28b33de33..b0c8fcd25418 100644
--- a/games-kids/gmult/gmult-10.0.ebuild
+++ b/games-kids/gmult/gmult-10.0.ebuild
@@ -26,6 +26,10 @@ BDEPEND="
$(vala_depend)
sys-devel/gettext"
+PATCHES=(
+ "${FILESDIR}"/${PN}-10.0-no-icon-cache.patch
+)
+
DOCS=( NEWS.md README.md )
src_configure() {