summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-11 16:02:18 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-11 17:55:47 -0500
commit0b609ecc756824fc76576755337fc35d74bb5688 (patch)
tree8105ece71fd162927338186f477f55f0fb16f31c /games-misc/c++robots
parentgames-misc/bsod: remove deprecated games eclass (diff)
downloadgentoo-0b609ecc756824fc76576755337fc35d74bb5688.tar.gz
gentoo-0b609ecc756824fc76576755337fc35d74bb5688.tar.bz2
gentoo-0b609ecc756824fc76576755337fc35d74bb5688.zip
games-misc/c++robots: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-misc/c++robots')
-rw-r--r--games-misc/c++robots/c++robots-0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-misc/c++robots/c++robots-0-r1.ebuild b/games-misc/c++robots/c++robots-0-r1.ebuild
new file mode 100644
index 000000000000..d92a5a7d1aab
--- /dev/null
+++ b/games-misc/c++robots/c++robots-0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="ongoing 'King of the Hill' (KotH) tournament"
+HOMEPAGE="http://www.gamerz.net/c++robots/"
+SRC_URI="http://www.gamerz.net/c++robots/c++robots.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="static"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}/proper-coding.patch"
+)
+
+src_compile() {
+ local myldflags="${LDFLAGS}"
+ use static && myldflags="${myldflags} -static"
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${myldflags}"
+}
+
+src_install() {
+ dobin combat cylon target tracker
+ dodoc README
+}