summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/cowsay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/cowsay')
-rw-r--r--games-misc/cowsay/Manifest1
-rw-r--r--games-misc/cowsay/cowsay-3.03-r2.ebuild42
-rw-r--r--games-misc/cowsay/files/cowsay-3.03-mech.patch18
-rw-r--r--games-misc/cowsay/files/cowsay-3.03-tongue.patch10
-rw-r--r--games-misc/cowsay/files/cowsay-3.03-utf8.patch17
-rw-r--r--games-misc/cowsay/metadata.xml5
6 files changed, 93 insertions, 0 deletions
diff --git a/games-misc/cowsay/Manifest b/games-misc/cowsay/Manifest
new file mode 100644
index 000000000000..d9324add2bd9
--- /dev/null
+++ b/games-misc/cowsay/Manifest
@@ -0,0 +1 @@
+DIST cowsay-3.03.tar.gz 15189 SHA256 0b8672a7ac2b51183780db72618b42af8ec1ce02f6c05fe612510b650540b2af SHA512 8e91d0c929c2e0743106c08643029a943d0684343ff44ad8ff172636a8f47fd25ee8bc4d108ccfe308c756d2871b956cceef0c406800615ed0dc1e1e24648219 WHIRLPOOL 08b1f7818c073390dd4061e955888d5344b8d091b1a7ec12eeeb9d584b084e3a3e630fa03a6da3c80721f59e5d8ba10cffc677b892304fc900136fed110e7e87
diff --git a/games-misc/cowsay/cowsay-3.03-r2.ebuild b/games-misc/cowsay/cowsay-3.03-r2.ebuild
new file mode 100644
index 000000000000..5e10c29a36ad
--- /dev/null
+++ b/games-misc/cowsay/cowsay-3.03-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="configurable talking ASCII cow (and other characters)"
+HOMEPAGE="http://www.nog.net/~tony/warez/cowsay.shtml"
+SRC_URI="http://www.nog.net/~tony/warez/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x64-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5"
+
+src_prepare() {
+ sed -i \
+ -e "1 c\#!${EPREFIX}/usr/bin/perl"\
+ -e 's/\$version/\$VERSION/g'\
+ -e "s:%PREFIX%/share/cows:${EPREFIX}/usr/share/${P}/cows:" \
+ -e '/getopts/ i\$Getopt::Std::STANDARD_HELP_VERSION=1;' cowsay \
+ || die "sed cowsay failed"
+ sed -i \
+ -e "s|%PREFIX%/share/cows|${EPREFIX}/usr/share/${P}/cows|" cowsay.1 \
+ || die "sed cowsay.1 failed"
+ epatch \
+ "${FILESDIR}/${P}"-tongue.patch \
+ "${FILESDIR}/${P}"-mech.patch \
+ "${FILESDIR}/${P}"-utf8.patch
+}
+
+src_install() {
+ dobin cowsay
+ doman cowsay.1
+ dosym cowsay /usr/bin/cowthink
+ dosym cowsay.1 /usr/share/man/man1/cowthink.1
+ dodir /usr/share/${P}/cows
+ cp -r cows "${ED}"/usr/share/${P}/ || die "cp failed"
+}
diff --git a/games-misc/cowsay/files/cowsay-3.03-mech.patch b/games-misc/cowsay/files/cowsay-3.03-mech.patch
new file mode 100644
index 000000000000..10478ed6651d
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.03-mech.patch
@@ -0,0 +1,18 @@
+--- cows/mech-and-cow 2009-06-21 03:09:36.000000000 +0300
++++ cows/mech-and-cow.cow 2010-08-22 01:04:02.670000262 +0300
+@@ -1,3 +1,5 @@
++$the_cow = <<EOC;
++${thouts}
+ ,-----.
+ | |
+ ,--| |-.
+@@ -14,8 +16,4 @@
+ (__)\ )\/\ /' / | `i
+ ||----w | ___,;`----'.___L_,-'`\__
+ || || i_____;----\.____i""\____\
+-
+-
+-
+-
+-
++EOC
diff --git a/games-misc/cowsay/files/cowsay-3.03-tongue.patch b/games-misc/cowsay/files/cowsay-3.03-tongue.patch
new file mode 100644
index 000000000000..517e96709c23
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.03-tongue.patch
@@ -0,0 +1,10 @@
+--- cows/head-in.cow.old 2007-05-09 20:28:08.000000000 +0200
++++ cows/head-in.cow 2007-05-09 20:29:32.000000000 +0200
+@@ -7,6 +7,6 @@
+ ^__^ /
+ ($eyes)\\_______/ _________
+ (__)\\ )=( ____|_ \\_____
+- $tongue ||----w | \\ \\ \\_____ |
++ $tongue ||----w | \\ \\ \\_____ |
+ || || || ||
+ EOC
diff --git a/games-misc/cowsay/files/cowsay-3.03-utf8.patch b/games-misc/cowsay/files/cowsay-3.03-utf8.patch
new file mode 100644
index 000000000000..6aed9c149e3d
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.03-utf8.patch
@@ -0,0 +1,17 @@
+diff -Naur cowsay-3.03.orig//cowsay cowsay-3.03/cowsay
+--- cowsay-3.03.orig//cowsay 2011-04-21 16:36:03.581377699 +0200
++++ cowsay-3.03/cowsay 2011-04-21 16:37:07.968430100 +0200
+@@ -12,6 +12,13 @@
+ use Getopt::Std;
+ use Cwd;
+
++if (${^UTF8LOCALE}) {
++ binmode STDIN, ':utf8';
++ binmode STDOUT, ':utf8';
++ require Encode;
++ eval { $_ = Encode::decode_utf8($_,1) } for @ARGV;
++}
++
+ $VERSION = "3.03";
+ $progname = basename($0);
+ $eyes = "oo";
diff --git a/games-misc/cowsay/metadata.xml b/games-misc/cowsay/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-misc/cowsay/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>