summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-01 08:01:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-01 19:18:44 -0400
commitabca26c97cbac05c2d5ed56a288b7d115b0ee12d (patch)
treef9a7757a2460c0ea7fc07214b4f7761043e28894 /games-misc/nyancat/nyancat-1.5.2.ebuild
parentdev-python/pytest-cov: Bump to 2.12.1 (diff)
downloadgentoo-abca26c97cbac05c2d5ed56a288b7d115b0ee12d.tar.gz
gentoo-abca26c97cbac05c2d5ed56a288b7d115b0ee12d.tar.bz2
gentoo-abca26c97cbac05c2d5ed56a288b7d115b0ee12d.zip
games-misc/nyancat: add 1.5.2, EAPI-7
Now also installing the man page and systemd units. Closes: https://bugs.gentoo.org/738090 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-misc/nyancat/nyancat-1.5.2.ebuild')
-rw-r--r--games-misc/nyancat/nyancat-1.5.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-misc/nyancat/nyancat-1.5.2.ebuild b/games-misc/nyancat/nyancat-1.5.2.ebuild
new file mode 100644
index 000000000000..19dce0d65b5a
--- /dev/null
+++ b/games-misc/nyancat/nyancat-1.5.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Nyancat in your terminal, rendered through ANSI escape sequences"
+HOMEPAGE="https://nyancat.dakko.us/"
+SRC_URI="https://github.com/klange/nyancat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin src/${PN}
+ doman ${PN}.1
+ einstalldocs
+ systemd_dounit systemd/${PN}{.socket,@.service}
+}