summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/opengfx/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/opengfx/files')
-rw-r--r--games-misc/opengfx/files/opengfx-0.5.1-gcc48.patch16
-rw-r--r--games-misc/opengfx/files/opengfx-0.5.2-Makefile.patch45
2 files changed, 61 insertions, 0 deletions
diff --git a/games-misc/opengfx/files/opengfx-0.5.1-gcc48.patch b/games-misc/opengfx/files/opengfx-0.5.1-gcc48.patch
new file mode 100644
index 000000000000..51a32c8766b7
--- /dev/null
+++ b/games-misc/opengfx/files/opengfx-0.5.1-gcc48.patch
@@ -0,0 +1,16 @@
+--- scripts/Makefile.nml.old
++++ scripts/Makefile.nml
+@@ -14,11 +14,11 @@
+
+ %.src.dep: $(SRC_DIR)/%.pnml
+ $(_E) "[DEP] $@"
+- $(_V) $(CC) -C -M -MF $@ -E -MT $(patsubst %.src.dep,%.nml,$@) - < $<
++ $(_V) $(CC) -P -C -M -MF $@ -E -MT $(patsubst %.src.dep,%.nml,$@) - < $<
+
+ %.nml: $(SRC_DIR)/%.pnml $(TAG_FILENAME)
+ $(_E) "[CPP] $@"
+- $(_V) $(CC) -D REPO_REVISION=$(REPO_REVISION) $(CC_FLAGS) $< > $@
++ $(_V) $(CC) -P -D REPO_REVISION=$(REPO_REVISION) $(CC_FLAGS) $< > $@
+
+ %.gfx.dep: %.nml
+ $(_E) "[DEP] $@"
diff --git a/games-misc/opengfx/files/opengfx-0.5.2-Makefile.patch b/games-misc/opengfx/files/opengfx-0.5.2-Makefile.patch
new file mode 100644
index 000000000000..ee301b8190f4
--- /dev/null
+++ b/games-misc/opengfx/files/opengfx-0.5.2-Makefile.patch
@@ -0,0 +1,45 @@
+diff -ru opengfx-0.5.2-source.orig/Makefile opengfx-0.5.2-source/Makefile
+--- opengfx-0.5.2-source.orig/Makefile 2015-04-12 12:57:17.000000000 -0400
++++ opengfx-0.5.2-source/Makefile 2015-07-28 21:13:46.496708233 -0400
+@@ -99,8 +99,8 @@
+ AWK ?= awk
+ GREP ?= grep
+ PYTHON ?= python
+-UNIX2DOS ?= unix2dos
+-UNIX2DOS_FLAGS ?= $(shell [ -n $(UNIX2DOS) ] && $(UNIX2DOS) -q --version 2>/dev/null && echo "-q" || echo "")
++UNIX2DOS ?= $(shell which unix2dos 2>/dev/null)
++UNIX2DOS_FLAGS ?= $(shell [ -n $(UNIX2DOS) ] && $(UNIX2DOS) -q --version 2>/dev/null >&2 && echo "-q" || echo "")
+
+ # Graphics processing
+ GIMP ?= gimp
+@@ -196,7 +196,7 @@
+ endif
+
+ # Days of commit since 2000-1-1 00-00
+-REPO_DAYS_SINCE_2000 ?= $(shell $(PYTHON) -c "from datetime import date; print (date(`echo "$(REPO_DATE)" | sed s/-/,/g | sed s/,0/,/g`)-date(2000,1,1)).days")
++REPO_DAYS_SINCE_2000 ?= $(shell $(PYTHON) -c "from datetime import date; print ((date(`echo "$(REPO_DATE)" | sed s/-/,/g | sed s/,0/,/g`)-date(2000,1,1)).days)")
+
+ # Filename addition, if we're not building the default branch
+ REPO_BRANCH_STRING ?= $(shell if [ "$(REPO_BRANCH)" = "$(DEFAULT_BRANCH_NAME)" ]; then echo ""; else echo "-$(REPO_BRANCH)"; fi)
+@@ -377,7 +377,11 @@
+ | sed -e "s/$(REPLACE_REVISION)/$(NEWGRF_VERSION)/" \
+ | sed -e "s/$(REPLACE_FILENAME)/$(OUTPUT_FILENAME)/" \
+ > $@
+- $(_V) [ -z "$(UNIX2DOS)" ] || $(UNIX2DOS) $(UNIX2DOS_FLAGS) $@
++ifeq ($(UNIX2DOS),)
++ $(_E) Warning: unix2dos not available. $@ keeps current eol style.
++else
++ $(_V) $(UNIX2DOS) $(UNIX2DOS_FLAGS) $@
++endif
+
+ clean::
+ $(_E) "[CLEAN DOC]"
+@@ -714,7 +718,7 @@
+ $(_E)
+ endif
+ $(_E) "Release:"
+- $(_E) "bananas: Upload bundle to BaNaNaS
++ $(_E) "bananas: Upload bundle to BaNaNaS"
+ $(_E)
+ $(_E) "Valid command line variables are:"
+ $(_E) "Helper programmes:"