summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 14:09:45 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 14:09:45 +0100
commit128161f385aaafeefcaafea80549d3e49ee9096e (patch)
tree5c593d88010610e2db960557fd72db25cdc0c65f /games-misc
parentgames-engines/scummvm-tools: add 2.7.0_p1 (diff)
downloadgentoo-128161f385aaafeefcaafea80549d3e49ee9096e.tar.gz
gentoo-128161f385aaafeefcaafea80549d3e49ee9096e.tar.bz2
gentoo-128161f385aaafeefcaafea80549d3e49ee9096e.zip
games-misc/sound-of-sorting: add 0.6.6_pre20221012
Closes: https://bugs.gentoo.org/581384 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/sound-of-sorting/Manifest2
-rw-r--r--games-misc/sound-of-sorting/sound-of-sorting-0.6.6_pre20221012.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/games-misc/sound-of-sorting/Manifest b/games-misc/sound-of-sorting/Manifest
index 459545f462fb..7912fc995d2e 100644
--- a/games-misc/sound-of-sorting/Manifest
+++ b/games-misc/sound-of-sorting/Manifest
@@ -1 +1,3 @@
DIST sound-of-sorting-0.6.6_pre20151107.tar.gz 179044 BLAKE2B 8027851e63cf8f3a0cec7e184b1970b9a138bcaa10b345e9fd742950bc397a7eb3d6911fbf8138eab3418c66788c6218b74ed03c1e6e72374b4b7dab0ce06387 SHA512 530caeefe4a37fed401ce56803900806a86efc1e4c0ff083c52e4bfc1cf78f8158539ca3c22f5cdf5cd176c8d6953089d14ca855643ce353457419a4f931a125
+DIST sound-of-sorting-0.6.6_pre20221012.tar.gz 196461 BLAKE2B 18eb44619078bd823a3bed4a97e29080d8e0d3fdf8ca56841d73c15af0c1b8d1c57852b77675c4abcaca4ab15fa66983f8066ff052e98e8e2f25d1ae3b4084fd SHA512 a1fb025031e3dc808b860eb53fc7e44253949e1d40044315fdf8ae55fe264501a3fc056504d2914d437a843b040da2fdc70c9ebd2a8c3c6b2bd46aed756f5522
+DIST sound-of-sorting_512.png 6357 BLAKE2B 73129edf24f7872b11d5b80a826afacaaaae7bbbdbfbe5ca06dde9e1713fa3ae6b899a9c9eeb670ad38e6c028b00a708e08c068c7c68ef8270e93703ec111030 SHA512 8b225715c9012277259a78c96d7727f58f8f7f8320526f0090fdd3a7356fe2b49c4f5e91ef55898fe9f91226268f4c3ba4d5b4337f33b690827610f6564bf1d9
diff --git a/games-misc/sound-of-sorting/sound-of-sorting-0.6.6_pre20221012.ebuild b/games-misc/sound-of-sorting/sound-of-sorting-0.6.6_pre20221012.ebuild
new file mode 100644
index 000000000000..581335908ae2
--- /dev/null
+++ b/games-misc/sound-of-sorting/sound-of-sorting-0.6.6_pre20221012.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.2-gtk3"
+
+inherit desktop wxwidgets xdg
+
+DESCRIPTION="Visualization and Audibilization of Sorting Algorithms"
+HOMEPAGE="http://panthema.net/2013/sound-of-sorting/ https://github.com/bingmann/sound-of-sorting"
+#SRC_URI="http://panthema.net/2013/sound-of-sorting/${P}.tar.bz2"
+COMMIT="5cfcaf752593c8cbcf52555dd22745599a7d8b1b"
+SRC_URI="https://github.com/bingmann/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~pacho/${PN}/${PN}_512.png"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-libs/libsdl
+ x11-libs/wxGTK:${WX_GTK_VER}
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ setup-wxwidgets unicode
+ default
+}
+
+src_install() {
+ default
+ make_desktop_entry ${PN} "Sound of Sorting"
+ newicon -s 512 "${DISTDIR}/${PN}_512.png" ${PN}.png
+}