summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-03 15:59:42 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-03 16:03:04 +0100
commit25cb9482e44c02f1bd177bafe554710316127021 (patch)
treedce6c65b2d60288c5ed000c8d27c6360dd108f14 /games-misc
parentapp-benchmarks/stress-ng: drop 0.13.10 (diff)
downloadgentoo-25cb9482e44c02f1bd177bafe554710316127021.tar.gz
gentoo-25cb9482e44c02f1bd177bafe554710316127021.tar.bz2
gentoo-25cb9482e44c02f1bd177bafe554710316127021.zip
games-misc/xcowsay: add 1.6
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/xcowsay/Manifest1
-rw-r--r--games-misc/xcowsay/xcowsay-1.6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/games-misc/xcowsay/Manifest b/games-misc/xcowsay/Manifest
index a9444f62857a..49d77a08a571 100644
--- a/games-misc/xcowsay/Manifest
+++ b/games-misc/xcowsay/Manifest
@@ -1 +1,2 @@
DIST xcowsay-1.5.1.tar.gz 101281 BLAKE2B 568f6ad7225cd859c37d79bf3ddf66c184f47d8feb6dedbafbd29ca4e05d97d883c6d6e4f4d60cebe107f1527e1ff01e17ec61430a3e55e2f504c2c00e402488 SHA512 55c165b5b2c01b11463af0eeb13fd646ea50138e2938ddfc25d44f1a704b7473d047bc7c95165f449a600de51ee005904f007843e33a8ef02c725b827eaec616
+DIST xcowsay-1.6.tar.gz 292845 BLAKE2B 88597063616928edfc74830171b287b676163faca0b3545dc4495cb0faee810ca7867f36223bba726074866de7fb3458621670265250c846ce94c035a0ad0828 SHA512 53016e1b2790b8bc213702f1b99a0ca0cacc57ef1c2cf821814ecb4aff68df05c98b279a1f39718f4fcee771e1397b27ad43123314b1f04dd442ddc0520a9f98
diff --git a/games-misc/xcowsay/xcowsay-1.6.ebuild b/games-misc/xcowsay/xcowsay-1.6.ebuild
new file mode 100644
index 000000000000..d88c858a28ff
--- /dev/null
+++ b/games-misc/xcowsay/xcowsay-1.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Displays a cute cow and message on your desktop"
+HOMEPAGE="
+ https://github.com/nickg/xcowsay
+ https://www.doof.me.uk/xcowsay/
+"
+SRC_URI="https://github.com/nickg/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus fortune nls"
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ dbus? ( dev-libs/dbus-glib )
+ fortune? ( games-misc/fortune-mod )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ if ! use fortune; then
+ sed -e 's/xcowfortune//g' -i src/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable dbus)
+ $(use_enable nls)
+ )
+
+ econf ${myeconfargs[@]}
+}