summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 11:40:55 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:31:44 +0200
commitce0b1048195262f43080a60e7486132709b8ffe0 (patch)
tree5789d3f431d8749cbc39ea5d7acd2f86ca9806c6 /games-misc
parentgames-kids/memonix: Drop old (diff)
downloadgentoo-ce0b1048195262f43080a60e7486132709b8ffe0.tar.gz
gentoo-ce0b1048195262f43080a60e7486132709b8ffe0.tar.bz2
gentoo-ce0b1048195262f43080a60e7486132709b8ffe0.zip
games-misc/exult-sound: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/exult-sound/exult-sound-0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-misc/exult-sound/exult-sound-0-r1.ebuild b/games-misc/exult-sound/exult-sound-0-r1.ebuild
new file mode 100644
index 000000000000..d83c7ae5d659
--- /dev/null
+++ b/games-misc/exult-sound/exult-sound-0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Sound data for games-engines/exult"
+HOMEPAGE="http://exult.sourceforge.net/"
+SRC_URI="mirror://sourceforge/exult/U7MusicOGG_1of2.zip
+ mirror://sourceforge/exult/U7MusicOGG_2of2.zip
+ mirror://sourceforge/exult/jmsfx.zip
+ mirror://sourceforge/exult/jmsfxsi.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!<games-engines/exult-9999"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ mkdir music && cd music || die
+ unpack U7MusicOGG_{1,2}of2.zip
+ cd "${WORKDIR}" || die
+ mkdir flx && cd flx || die
+ unpack jmsfx{,si}.zip
+}
+
+src_install() {
+ insinto /usr/share/exult/music
+ doins "${WORKDIR}/music/"*ogg
+ insinto /usr/share/exult/
+ doins "${WORKDIR}/flx/"*.flx
+ newdoc "${WORKDIR}/music/readme.txt" music-readme.txt
+}