summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-29 21:34:35 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-29 21:35:10 +0200
commite49948414026fa60bba0ae42038f4b615fddba06 (patch)
treeee4fdb177141652d2e43d86cac6b169508a991d4 /games-misc
parentprofiles/archc/arm{,64}/use.mask: drop cblas-external mask (diff)
downloadgentoo-e49948414026fa60bba0ae42038f4b615fddba06.tar.gz
gentoo-e49948414026fa60bba0ae42038f4b615fddba06.tar.bz2
gentoo-e49948414026fa60bba0ae42038f4b615fddba06.zip
games-misc/ballerburg: Fix installation details
Closes: https://bugs.gentoo.org/730870 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild b/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..e4a987433010
--- /dev/null
+++ b/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Linux port of the classical Atari ST game Ballerburg"
+HOMEPAGE="http://baller.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/baller/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="media-libs/libsdl"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCDIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ gunzip "${ED}usr/share/man/man6/ballerburg.6.gz" || die
+}