summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 14:00:50 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 14:43:17 -0500
commita7119eef52411379b94400abe463dd5469abe1c3 (patch)
tree93a97412f837f03f2b856ebd27879689ca8fbad0 /games-mud/gnome-mud/gnome-mud-0.11.2-r1.ebuild
parentgames-mud/gmudix: remove deprecated games eclass (diff)
downloadgentoo-a7119eef52411379b94400abe463dd5469abe1c3.tar.gz
gentoo-a7119eef52411379b94400abe463dd5469abe1c3.tar.bz2
gentoo-a7119eef52411379b94400abe463dd5469abe1c3.zip
games-mud/gnome-mud: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-mud/gnome-mud/gnome-mud-0.11.2-r1.ebuild')
-rw-r--r--games-mud/gnome-mud/gnome-mud-0.11.2-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-mud/gnome-mud/gnome-mud-0.11.2-r1.ebuild b/games-mud/gnome-mud/gnome-mud-0.11.2-r1.ebuild
new file mode 100644
index 000000000000..f50488cf4055
--- /dev/null
+++ b/games-mud/gnome-mud/gnome-mud-0.11.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="GNOME MUD client"
+HOMEPAGE="https://wiki.gnome.org/Apps/GnomeMud"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gstreamer"
+
+RDEPEND="virtual/libintl
+ dev-libs/libpcre
+ dev-perl/XML-Parser
+ gnome-base/gconf:2
+ >=gnome-base/libglade-2.0.1:2.0
+ gstreamer? ( media-libs/gstreamer:0.10 )
+ net-libs/gnet:2
+ x11-libs/gtk+:2
+ >=x11-libs/vte-0.11:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/rarian
+ >=dev-util/intltool-0.23
+ >=sys-devel/gettext-0.11.5"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gstreamer)
+}
+
+src_install() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS PLUGIN.API README ROADMAP" \
+ gnome2_src_install
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ echo
+ elog "For proper plugin operation, please create ~/.gnome-mud/plugins/"
+ elog "if that directory doesn't already exist."
+ elog "The command to do that is:"
+ elog " mkdir -p ~/.gnome-mud/plugins/"
+ echo
+}