summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-11 08:55:41 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-11 08:56:33 +0000
commitf34612bd02991c8a9c792397e6a239d8289215bd (patch)
tree32e717644d6d2d6169fbf818bbe916a1e67219af /games-puzzle/brainparty
parentgames-puzzle/brainparty: tweak for gcc-11 (diff)
downloadgentoo-f34612bd02991c8a9c792397e6a239d8289215bd.tar.gz
gentoo-f34612bd02991c8a9c792397e6a239d8289215bd.tar.bz2
gentoo-f34612bd02991c8a9c792397e6a239d8289215bd.zip
games-puzzle/brainparty: tweak for clang-11
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/739284 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-puzzle/brainparty')
-rw-r--r--games-puzzle/brainparty/brainparty-0.61-r1.ebuild1
-rw-r--r--games-puzzle/brainparty/files/brainparty-0.61-clang-11.patch14
2 files changed, 15 insertions, 0 deletions
diff --git a/games-puzzle/brainparty/brainparty-0.61-r1.ebuild b/games-puzzle/brainparty/brainparty-0.61-r1.ebuild
index 2400e1405d14..6f6b8eeb9c5a 100644
--- a/games-puzzle/brainparty/brainparty-0.61-r1.ebuild
+++ b/games-puzzle/brainparty/brainparty-0.61-r1.ebuild
@@ -29,6 +29,7 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc49.patch
"${FILESDIR}"/${P}-gnu_cxx-hash.patch
"${FILESDIR}"/${P}-gcc-11.patch
+ "${FILESDIR}"/${P}-clang-11.patch
)
src_prepare() {
diff --git a/games-puzzle/brainparty/files/brainparty-0.61-clang-11.patch b/games-puzzle/brainparty/files/brainparty-0.61-clang-11.patch
new file mode 100644
index 000000000000..07c1b9709932
--- /dev/null
+++ b/games-puzzle/brainparty/files/brainparty-0.61-clang-11.patch
@@ -0,0 +1,14 @@
+clang-11 needs explicit cast
+
+https://bugs.gentoo.org/739284
+--- a/BPGame.cpp
++++ b/BPGame.cpp
+@@ -1507,7 +1507,7 @@ int BPGame::DivRem(int Num, int Div, int* Rem) {
+ }
+
+ void BPGame::DrawLine(int fromx, int fromy, int tox, int toy, Colour* col, float width) {
+- GLfloat vertices[] = { fromx, fromy, tox, toy };
++ GLfloat vertices[] = { (GLfloat)fromx, (GLfloat)fromy, (GLfloat)tox, (GLfloat)toy };
+
+ glDisable(GL_TEXTURE_2D);
+ glLineWidth(width);