summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-11 19:35:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-11 20:34:33 +0200
commit9b129451619262342f9e5591f2b7a5ddd933db18 (patch)
treeee2b7705a14cc0058c1fa9f2d7432214e61102a4 /games-puzzle/cutemaze/cutemaze-1.2.3.ebuild
parentgames-puzzle/connectagram: Drop old (diff)
downloadgentoo-9b129451619262342f9e5591f2b7a5ddd933db18.tar.gz
gentoo-9b129451619262342f9e5591f2b7a5ddd933db18.tar.bz2
gentoo-9b129451619262342f9e5591f2b7a5ddd933db18.zip
games-puzzle/cutemaze: 1.2.3 version bump
Fixes qmake with Qt 5.11. Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/cutemaze/cutemaze-1.2.3.ebuild')
-rw-r--r--games-puzzle/cutemaze/cutemaze-1.2.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/cutemaze/cutemaze-1.2.3.ebuild b/games-puzzle/cutemaze/cutemaze-1.2.3.ebuild
new file mode 100644
index 000000000000..0f3981c5b115
--- /dev/null
+++ b/games-puzzle/cutemaze/cutemaze-1.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils
+
+DESCRIPTION="A simple, top-down game in which mazes are randomly generated"
+HOMEPAGE="https://gottcode.org/cutemaze/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5 PREFIX="/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}