summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-18 14:47:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-18 14:47:01 +0200
commit46955a32bc067d9550a3389271963e0a92b628c8 (patch)
tree5f0d4dcfa2fa5a63ed03796bb2197d95ddc25b7c /games-puzzle/galaxis
parentsys-apps/iproute2: Replaced "echo -n" with "printf" (diff)
downloadgentoo-46955a32bc067d9550a3389271963e0a92b628c8.tar.gz
gentoo-46955a32bc067d9550a3389271963e0a92b628c8.tar.bz2
gentoo-46955a32bc067d9550a3389271963e0a92b628c8.zip
games-puzzle/galaxis: Fixed build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/690080 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-puzzle/galaxis')
-rw-r--r--games-puzzle/galaxis/galaxis-1.8-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-puzzle/galaxis/galaxis-1.8-r1.ebuild b/games-puzzle/galaxis/galaxis-1.8-r1.ebuild
index 73020c4a91e1..d646f5a94a2b 100644
--- a/games-puzzle/galaxis/galaxis-1.8-r1.ebuild
+++ b/games-puzzle/galaxis/galaxis-1.8-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Curses-based clone of the nifty little Macintosh freeware game Galaxis"
HOMEPAGE="http://www.catb.org/~esr/galaxis/"
@@ -14,9 +16,15 @@ IUSE=""
DEPEND=">=sys-libs/ncurses-5.3:0="
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+src_compile() {
+ local PKGCONFIG="$(tc-getPKG_CONFIG)"
+ emake TERMLIB="$(${PKGCONFIG} --libs ncurses)"
+}
+
src_install() {
dobin galaxis
doman galaxis.6